PIM ENTM: エンタープライズ管理画面にログインできない
search cancel

PIM ENTM: エンタープライズ管理画面にログインできない

book

Article ID: 276232

calendar_today

Updated On:

Products

CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

Privileged Identity Manager ( 以下、 PIM) のエンタープライズ管理コンソールにログインしようとすると以下のエラーメッセージが出て、ログインできない。

Error server is unavailable, No ManagedConnections available within configured blocking timeout ( 175000 [ms] ); - nested throwable: (javax.resource.ResourceException: No ManagedConnections available within configured blocking timeout ( 175000 [ms] ))

 

Environment

Privileged Identity Manager 12.8, 12.9, 14.0  ( エンタープライズ管理 )
Privileged Access Manager Server Control 14.0  ( エンタープライズ管理 )

Cause

本エラーは JBoss で管理しているバックエンドのデータベースとの接続タスクが最大数を超えた場合に発生します。

Resolution

以下のいずれかを行って対応してください。

  • 接続タスクをリセットするためにJBossの再起動を行います。
  • このエラーが頻繁に発生する場合は以下の設定ファイルで max-pool-size の値を更新します。
    設定後はJBossの再起動が必要になります。
    また、値の更新は少しずつ増加させて、事象の頻度が下がるか、発生しなくなるような値を確認しながら行ってください。
    <JBossインストールディレクトリ>\server\default\deploy 配下
      imtaskpersistencedb-ds.xml
      objectstore-ds.xml

JBossの再起動時には <JBossインストールディレクトリ>\server\default 以下のtmp、workディレクトリ配下のファイルをすべて削除することを強く推奨とさせていただきます。

Additional Information

なお、本KBは以下の英文 KB を翻訳し補足しました。

Article ID: 37955: Cannot login to Enterprise Manger due to error with managed connections.