Access Gateway installer does not recognize JDK 11.0.20 - Invalid JDK/JVM error or installer fails to launch
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Access Gateway installer does not recognize JDK 11.0.20 - Invalid JDK/JVM error or installer fails to launch

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Article ID: 275892

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Updated On:

Products

CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) SITEMINDER

Issue/Introduction

Access Gateway R12.8.7 installer is not recognizing JDK 11.0.20 and higher, reporting 'Invalid JDK Version' on Windows and 'Please select another JVM' on Unix.  In some Windows environments the installer may fail to launch with no error message.

OS: Red Hat, Windows, Solaris
Java: Oracle or AdoptOpenJDK 11.0.20 or newer (versions prior to this are unaffected)

Unix Error:


Windows Error:

On Windows, if the path to the Java installation is included in the PATH environment variable, the installer may fail to launch without displaying any error.  This is caused by the same problem as the error above and has the same solution.  If you run the installer in debug mode (hold the ctrl key while launching the installer to run debug mode), you will see the following output:

Environment

Release : 12.8.6 through 12.8.8

OS: All Supported Operating Systems (Windows, Red Hat, Solaris)
JDK 11.0.20 or newer

Cause

This is due to changes in the Java release 11.0.20.  The Access Gateway installer uses Java and is thus affected when run on a system with Java 11.0.20 or higher.

https://www.oracle.com/java/technologies/javase/11-0-20-relnotes.html

core-libs/java.util.jar
➜ Improved ZIP64 Extra Field Validation (JDK-8302483 (not public))
java.util.zip.ZipFile has been updated to provide additional validation of ZIP64 extra fields when opening a ZIP file. This validation may be disabled by setting the system property jdk.util.zip.disableZip64ExtraFieldValidation to true

 

 

Resolution

This will be fixed in a future release.

If you are experiencing this problem in release 12.8.7 or older, please follow these instructions to work around the problem:

For Unix platforms:

Set the following environment variable, then start the installation:
JAVA_TOOL_OPTIONS='-Djdk.util.zip.disableZip64ExtraFieldValidation=true'

 

For Windows Platforms:

Set the following environment variable, then start the installation:
_JAVA_OPTIONS=-Djdk.util.zip.disableZip64ExtraFieldValidation=true

Additional Information

This problem also affects the Policy Server installer program and has the same workaround.  You can view the Policy Server version of this document here: Policy Server installer does not recognize AdoptOpenJDK 11.0.20 - Invalid JRE Path