PAMSC All: DMS および ActiveMQの初期化について
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PAMSC All: DMS および ActiveMQの初期化について

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Article ID: 274173

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CA Privileged Access Manager - Server Control (PAMSC) CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Privileged Access Manager Server Control ( 以下、PAMSC) のエンタープライズ管理を使用しているときに、DMS / DH 初期化の方法を教えてほしい 。

Environment

Release : 14.1

Cause

DMS / DH 間の問題が発生した場合、メッセージキューの kahadb フォルダサイズが極端に大きくなっており、ディスク容量を圧迫していることがあります。
ここで、ActiveMQ のフォルダ( kahadb )および、DMS/DH の初期化の方法について説明させていただきます。
ファイルシステムの圧迫を回避するためにも ActiveMQ のフォルダの削除については定期的に行うことを推奨とさせていただきます。

Resolution

DMS/DH 初期化は以下のステップで行います。

  1. 最初にDMS__ のメッセージキューからサブスクライバをアンサブスクライブします。 
    Unsubscribe: C:\> sepmd -u DMS__ "Topic: ac_server_to_server_broadcast (DH)"
  2. PAMSC関連のサービスをすべて停止します。
  3. メッセージキューを全部パージします。
    手動での削除は下記に記載します。
  4. 全てのDistribution Serverで DH__.statusファイルを削除します。 
  5. DMS__サーバのフォルダで DMS__ status、 updates.dat、及び、全てのsubscribers.* を削除します。 
  6. 念のためにメッセージキューでペンディング状態がないかを確認します。 
  7. PAMSCのサービスを起動 
  8. 削除したファイル等が再作成されていることを確認します。 
    例えば、updates.dat は0バイトとなっているはずです。 
  9. DMS__ に DH__を再度サブスクライブします。 
    C:\> sepmd -smq DMS__ -predefined ServerToServerBroadcast -destination DH
  10. メッセージが正しく送られることを確認します。

 
ActiveMQのフォルダ (kahadb) の削除方法: フォルダの削除

  1. ActiveMQのサービス (CA PAM SC ActiveMQ Broker) 停止
  2. C:\ActiveMQ\data (デフォルトのパス) に移動して kahadb をリネームする。
  3. ActiveMQのサービス開始

サービス再起動で新しいフォルダが作成されます。

GUIでActiveMQのデータをパージする方法は以下の KB もご参照ください。

Article ID: 274305
Article Title: PIM/PAMSC 14.x: ActiveMQのジャーナルファイル db-XXX.log の削除方法について

Additional Information

以下の英文 KBを翻訳し補足しました。

Article ID: 269095: How to Clean up DMS and ActiveMQ?