To stop Nolio services on the NAC Server, it takes a long time after update to 6.7.8
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To stop Nolio services on the NAC Server, it takes a long time after update to 6.7.8

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Article ID: 273695

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

To stop Nolio services on the NAC Server after update from 6.7.0 to 6.7.8, it takes a long time with this message :

[<user1>@<hostname>]$ sudo -u <user2> ./nolio_server.sh stop
Using CATALINA_BASE:   /opt/Broadcom/ReleaseAutomationServer
Using CATALINA_HOME:   /opt/Broadcom/ReleaseAutomationServer
Using CATALINA_TMPDIR: /opt/Broadcom/ReleaseAutomationServer/temp
Using JRE_HOME:        ./jre
Using CLASSPATH:       /opt/Broadcom/ReleaseAutomationServer/bin/bootstrap.jar:/opt/Broadcom/ReleaseAutomationServer/bin/tomcat-juli.jar
Using CATALINA_OPTS:
Using CATALINA_PID:    ./catalina.pid
Tomcat did not stop in time.
To aid diagnostics a thread dump has been written to standard out.
Killing Tomcat with the PID: 9116
The Tomcat process has been killed.


Even trying to delete temp folders and the LevelDB folders the issue is still the same.

Environment

Release : 6.7.8, 6.8

Cause

Nolio RA 6.7 service doesn't stop with command "service NolioASAP stop" - Article ID: 246049

 

Resolution

This is expected if "Tomcat did not stop in time", then the updated 'nolio_server.sh stop' (since 6.7.7) forces it shutdown
after a short timeout, "The Tomcat process has been killed".

The fix is included since the 6.7.7  (it includes a timeout and force on stop):

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/release-automation-nolio/6-7/release-notes/release-notes-for-6-7-7.html

Nolio Release Automation 6.7
Release Notes
Release Notes for 6.7.7

Fixed Issues
Reference Number    Description
33065661    Error NAC/NES service NolioASAP stop

It has also been addressed in the 6.8.0.