SEPM cannot be successfully enrolled to SES cloud. "Devices and Device Groups sync is in progress" message is displayed in ICDm (SE cloud console) for a long time.
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SEPM cannot be successfully enrolled to SES cloud. "Devices and Device Groups sync is in progress" message is displayed in ICDm (SE cloud console) for a long time.

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Article ID: 272852

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Updated On:

Products

Endpoint Security Complete Endpoint Security Endpoint Protection

Issue/Introduction

After trying to enroll SEPM to SES cloud, the SEPM console shows successfully enrolled:

but SEPM-managed clients don't appear in ICDm and "Devices and Device Groups sync is in progress. Do not perform any operation until sync is complete." message keeps being displayed for a long time (even more than one day) after logging into ICDm:

 

C:\Program Files\Symantec Endpoint Protection Cloud Hub\etc\sensor.xml file on SEPM server contains the following entries:

<property name="DatabasePassword">password</property>
<property name="IsDatabasePasswordEncrypted">true</property>

, where password is the SEPM database password displayed in plain text (i.e. unencrypted).

Cause

Reset the Endpoint Protection Manager database password Improper entry exists in SEPM's sensor.xml file, that contains unencrypted database password, while the database password encryption is enabled.

The logs will show:

2025-01-23 13:19:15.462 [main] INFO  com.symantec.sensor.SensorModule - DB Asset Sensor - initializing... 
2025-01-23 13:19:15.588 [main] ERROR c.s.cas.ucf.sensors.DB.DBSensorModule - DB Asset Sensor - error in reading configuration. 
java.lang.NullPointerException: null

Resolution

1. Unenroll SEPM (from SEPM side - using the SEPM console). See: Enrolling and unenrolling Symantec Endpoint Protection Manager domains from the cloud server

2. Upgrade SEPM to the latest available version (this step is optional, recommended especially if the current SEPM version is older than 14.3 RU6). See: Upgrade best practices for Endpoint Protection 14.x

3. Run Management Server Configuration Wizard to change the SEPM database password:

  1. If SEPM uses the default Microsoft SQL Server Express database:
    • On the Windows Start menu, navigate to Symantec Endpoint Protection Manager > Management Server Configuration Wizard.
    • Click Reconfigure the management server, and then click Next > Next.
    • Click Change the database administrator password and type the new password.
    • Follow the instructions in each panel to finish the configuration.
  2. If SEPM uses external SQL Server database , see Reset the Endpoint Protection Manager database password

4. Reenroll SEPM into the cloud.

IF above doesn't work you can need to reinstall the Cloud hub services using:

Navigate to :

C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\data\sepmMetadata

The zip inside this folder the the cloud hub service you unzip , uninstall it and install it again.

Check now the Sensor.xml and Unroll the SEPM again.