UIM - HUB is not starting after Windows Updates
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UIM - HUB is not starting after Windows Updates

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Article ID: 271940

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

UIM primary hub not starting since installing the latest Windows updates and restarting the server. It looks like the controller is starting but none of the other probes are getting started (nimbus and controller.exe are running).

When trying to start HUB.exe manually, you get the following error: 

 

2904:error:24070079:random number generator:RAND_write_file:Cannot open file:crypto\rand\randfile.c:233:Filename=rand.rnd
2904:error:0308D076:bignum routines:BN_generate_prime_ex:bits too small:crypto\bn\bn_prime.c:66:
2904:error:0506A003:Diffie-Hellman routines:dh_builtin_genparams:BN lib:crypto\dh\bn_prime.c:66:

 

Environment

  • Release: 20.4 or later
  • HUB Tunnels

Cause

  • The problem was not determined 100%, but most likely after restarting the Windows systems, controller.cfg file and tunnel certificates were corrupted. 

Resolution

The error is probably related to tunnels and a corrupted SSL certificate.

In order to fix this issue, modify hub.cfg, by changing "active = yes" to "active = no" for all tunnels, save the configuration, and start the hub again. This time you should not get any errors. 

In order to fix this issue permanently, recreate the SSL certificate for all HUB tunnels.

Additional Information

For the controller .cfg file corruption issue (missing probes sections) : 

https://knowledge.broadcom.com/external/article/99180/ca-uim-hub-process-does-not-start-autom.html