CA UIM - hub process does not start automatically / Controller.cfg missing probe sections
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CA UIM - hub process does not start automatically / Controller.cfg missing probe sections

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Article ID: 99180

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

- The hub process does not start automatically after restarting the primary hub server. 
- Manually starting the hub.exe allows us to access IM however, most probes are missing and the remaining hub and controller probes do not start (in yellow status). 

Environment

Release:
Component: UIMHUB

Cause

UIM - Windows environment

Resolution

1. Go to Program Files (x86)\Nimsoft\hub and manually start the hub.exe process. 

2. Access Infrastructure Manager and check the status of the hub and probes. 

3. If most/all of the probes are missing, its most likely that the probe sections are missing from the controller.cfg, this is usually caused by a corruption of the controller.cfg. 
- Go to Nimsoft\robot, open the controller.cfg and confirm if probe sections are missing. 

4. Stop the Nimsoft service and kill the manually started hub.exe process. 

5. You will now need to re-add all of the required probe sections to the controller.cfg, if you have a copy of the controller.cfg or a secondary hub controller.cfg please use it. 
- I will attach a copy of my UIM 8.51 primary hub controller.cfg as an example which can be used (all magic_key entries removed). 

6. Once the probe sections are in place, you will need to remove all "magic_key = xxxxxxxxxxxx" entries from each probe section, example: 

- Before: 

<nas>
   description = Nimsoft Alarm Server
   group = Infrastructure
   active = yes
   type = daemon
   command = nas.exe
   config = nas.cfg
   logfile = nas.log
   workdir = probes/service/nas
   start_after = alarm_enrichment
   magic_key = <magic key>
</nas>

- After: 

<nas>
   description = Nimsoft Alarm Server
   group = Infrastructure
   active = yes
   type = daemon
   command = nas.exe
   config = nas.cfg
   logfile = nas.log
   workdir = probes/service/nas
   start_after = alarm_enrichment
</nas>

7. Once the above is complete, save the controller.cfg and restart the Nimsoft Service. 

8. Login to IM and re-validate security on all probes. 
- Select all probes -> Right Click -> Security -> Validate -> Yes All 

9. If a handful of probes still do not start, redeploy them from the local archive. 

Attachments

1558536471998controller.cfg.PrimaryHubCopy.UIM851.txt get_app