"Unexpected Server Error" appears during login to Endpoint Protection Manager console and when running Management Configuration Wizard.
search cancel

"Unexpected Server Error" appears during login to Endpoint Protection Manager console and when running Management Configuration Wizard.

book

Article ID: 267377

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When trying to login into Symantec Endpoint Manager (SEPM) you get the "Unexpected Server Error", after running repair and following through with the next steps in the Management Configuration Wizard you also get the "Unexpected Server Error".

Cause

In the scm-server logs you will see server configuration issues:

Caused by: java.lang.RuntimeException: Server is not configured correctly, please run Server Configuration Assistant!
    at com.sygate.scm.server.util.ScmProperties.<clinit>(ScmProperties.java:1683)

Follow by failed initialization of the scm properties:

2023-06-04 08:28:01.191 THREAD 34 SEVERE:  in: com.sygate.scm.server.servlet.ConsoleServlet
java.lang.NoClassDefFoundError: Could not initialize class com.sygate.scm.server.util.ScmProperties

In dbvalidator logs you might see SQL exceptions:
WARNING: lockProcessState exception:com.microsoft.sqlserver.jdbc.SQLServerException: Integrated authentication failed.

Resolution

Check the Conf.proerties file by navigating through: %Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\etc\conf.properties.

1. Edit Conf.properties.
2. Add scm.db.datasource= jdbc/metadatabase to the file.
3. Save the file.

After run the Management Server Configuration Wizard and login in to your SEPM.

If scm.db.datasource= jdbc/metadatabase  is already within the conf.properties file, please contact Symantec Endpoint Support.

Additional Information