Symantec Network Boot Service (TFTP) won't start on NBS Site Server
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Symantec Network Boot Service (TFTP) won't start on NBS Site Server

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Article ID: 261932

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Summary: The PXE boot process initiates successfully and the client acquires an IP address from the Site Server. However, the process fails during the TFTP phase.

Investigation: An inspection of the Site Server revealed that while the Symantec Network Boot Service (TFTP) is configured to start automatically, it was found in a stopped state. Attempting to manually restart the service resulted in it starting and immediately crashing/terminating.

From the SBSLog_TFTP.txt file you may see:

Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 922254729.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3362749833.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3357769097.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3608378761.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3358293385.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3362356617.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 4252007817.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 2071494025.
Mon Mar 13 14:19:16 2023  4572     SbsHostInfo.cpp     Sbs::HostInfo::InitInterfaces     157     Debug    Found IP address during interface initialization 3373825417.
Mon Mar 13 14:19:16 2023  4572     tftp.cpp            Sbs::TftpServer::SetRootFolder    568     Debug    Server root folder set to e:\Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS\Images
Mon Mar 13 14:19:16 2023  4572     tftp.cpp            Sbs::TftpServer::SetBlockSize     541     Debug    Server max block size set to 1456
Mon Mar 13 14:19:16 2023  4572     tftp.cpp            Sbs::TftpServer::SetInterfaceList  524    Debug    Server interface list changed.
Mon Mar 13 14:19:16 2023  4572     tftp.cpp            Sbs::TftpServer::SetupServer      894     Error    Windows error code 10049
Mon Mar 13 14:19:16 2023  4572     tftp.cpp            Sbs::TftpServer::Start            718     Error    Windows error code 10049
Mon Mar 13 14:19:16 2023  4572     sbsMtftp.cpp        Mtftp_Thread                      184     Debug    Mtftp_Thread: Stopping server.
Mon Mar 13 14:19:16 2023  4572     sbsMtftp.cpp        Mtftp_Thread                      188     Debug    Mtftp_Thread: Server stopped.

Environment

DS 8.x

Cause

"Windows error code 10049" indicates a network socket issue. It typically means an application or service tried to bind to an IP address that doesn’t exist on your computer, or an invalid address/port was assigned.

During installation of NBS, the TFTP service binds to a specific IP address. If the IP address of the NBS server changes after installation, this could result in the TFTP server not starting.

Resolution

Resolution Steps:

  1. If you know the original static IP address before it changed then set the Site Server back to that original IP address
  2. If you do not know the original IP address then uninstall and reinstall NBS:
    1. From the Notification Server, cd to: <install drive>:\Program Files\Altiris\Notification Server\NSCap\bin\Win64\x64\Deployment\SBS
    2. Copy the Symantec_DeploymentSolutionsSBS_8_6_x64.msi to the Site Server
    3. To uninstall enter: msiexec /x Symantec_DeploymentSolutionSBS_x64.msi
    4. To reinstall enter: msiexec /i Symantec_DeploymentSolutionSBS_x64.msi skipaim=1
    5. Send Basic Inventory from the Symantec Management Agent on the Site Server
    6. Run 'Resource Membership Update' ( delta and policy ) from the SMP Console at Settings > Notification Server > Resource Membership Update
    7. Rebuild the reboot configuration

Additional Information

Enable PXE Error Logging for Deployment Solution 8.x and later