Database connection error after re-installation of Ghost Solution Suite
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Database connection error after re-installation of Ghost Solution Suite

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Article ID: 261270

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

When opening Ghost Solution Suite console an error dialog box is displayed: 'Unable to connect to Database when starting GSS'
 
After reinstalling Ghost Solution Suite, the issue still occurs

Environment

Release : 3.3.x

SQL Server 2019 express

Cause

Using Microsoft SQL Server Management Studio found the eXpress Database was removed from the SQL Server

When reinstalling GSS the 'eXpress' Database would not be created or recreated

Resolution

Perform a complete uninstallation and reinstallation of GSS: 

https://knowledge.broadcom.com/external/article/163068/how-to-uninstallreinstall-ghost-solution.html

NOTE: it is not important to remove the directory C:\Program Files (x86)\Altiris as per the document. It is important when during the installation that when a dialog box states that the 'The share 'eXpress' is already in use on this machine. Do you want to replace the share? Click on 'Yes'

After installation reboot the server