ERROR: "Txpi 221: takesocket error 118" XCOM for z/VSE
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ERROR: "Txpi 221: takesocket error 118" XCOM for z/VSE

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Article ID: 260407

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Updated On:

Products

XCOM Data Transport

Issue/Introduction

Have installed XCOM 3.1 with all available maintenance from your solutions site on z/VSE 6.2 and getting below error when attempting a transfer between 2 VSE sites:

In initiating side XCOM job log:

XCOME0780E Txpi  226: Select timed out with no data available
XCOME0805I TCP/IP CONNECTION ENDED WITH IP=<IPaddress>
In receiving side the XCOM server log:
XCOME0780E Txpi  221: takesocket error 118.
XCOME0793I TCP/IP REMOTE CONNECTION ESTABLISHED FROM IP=       
XCOME0780E Txpi  221: takesocket error 118.
XCOME0780E Txpi  114: TxpiTerm for a server before TxpiInitConnection called for hClient 0X301.

The TCP/IP stack is at maintenance level 2.2.2 on each VSE site.

Environment

XCOM™ Data Transport® for z/VSE

Cause

The root cause of the problem was that the VSE CSI TC/IP stack was being used which is not supported with XCOM and only the VSE BSI TCP/IP stack is supported.

Resolution

Similar results were also found with loopback tests run on each site.
Also after the transfer failure it was observed that the listener port 8044 for XCOM was no longer listening.

The "FROM IP" being blank is due to nature of the socket failure to establish a connection and the "takesocket error 118".
The root cause of the problem is at the TCP/IP socket layer (XCOM XCOMM0780E TXPI Errors & RV meanings)
From z/VSE 6.2.0: Introducing Socket Programming page: ERRNO Values, takesocket error 118 means EFAULT "Bad address or buffer address not accessible."

The root cause of the problem was that the VSE CSI TC/IP stack was being used which is not supported with XCOM and only the VSE BSI TCP/IP stack is supported.
Further information is available from information solution RI77156 ("MISCELLANEOUS ERRORS WHEN RUNNING WITH THE CSI 1.5X STACK") and KB article CSI TCP/IP Stack Testing Status for XCOM for z/VSE 3.1