search cancel

テーブルの編集/削除/コピー/リネーム方法

book

Article ID: 255983

calendar_today

Updated On:

Products

OPS/MVS Event Management & Automation

Issue/Introduction

OPSMVSで使用するテーブルの内容を編集、コピーや削除、テーブル名のリネームをするにはどうすればいいですか?

Environment

Release : 14.0

Resolution

OPSVIEW 2.6パネルで可能です。

具体的には、以下のようになります。

(1) ”OPSVIEW Primary Options Menu” で2.6 を入力後、Enterキーを押下します。

CA OPS/MVS ------ xxxx ---  OPSVIEW Primary Options Menu  ----- Subsystem OPSS 
                                                                               
0  Parms      Set OPSVIEW and ISPF default values           User ID  - xxxxxxx 
1  OPSLOG     Browse OPSLOG                                 Time     - 10:03   
2  Editors    AOF Rules, REXX programs, SQL Tables          Level    - 14.0.05 
3  Sys Cntl   Display/Modify System Resources                                  
4  Control    Control CA OPS/MVS                                               
5  Support    Support information                                              
6  Command    Enter JES2/MVS/IMS/VM commands directly                          
7  Utilities  Run CA OPS/MVS Utilities                                         
I  ISPF       Use ISPF/PDF services                                            
S  SYSVIEW    CA SYSVIEW Performance Management                                
T  Tutorial   Display information about OPSVIEW                                
U  User       User-defined applications                                        
X  Exit       Exit OPSVIEW                                                     
                                                                               
                                                                               
CA OPS/MVS Event Management and Automation                                     
Copyright ユ 2020 Broadcom.  All rights reserved.                               
                                                                               
Press END or enter X to terminate OPSVIEW                                      
                                                                              
                                                                               
Option ===> 2.6                                                                
 F1=HELP      F2=SPLIT     F3=END       F4=RETURN    F5=RFIND     F6=RCHANGE   
 F7=UP        F8=DOWN      F9=SWAP     F10=LEFT     F11=RIGHT    F12=RETRIEVE  

 

(2) ”RDF Table Editor   Primary Menu” でEnterキーを押下します。

RDF Table Editor --------------- Primary Panel -------------------------------
Option ===>                                                                   
                                                                              
       B - Browse table                 C - Copy table                        
       E - Edit table                   R - Rename table                      
       I - Insert new table             F - Free table enq                    
       D - Delete table                 T - Transfer table contents           
      MD - Multi system table delete   MC - Multi system table copy           
      MT - Multi system table transfer                                        
                                                                              
                    blank - Display table list                                
                                                                              
Specify Relational Table (see note below):                                    
   Name     ===>                              (Required for B,C,D,E,F,R,T)    
   New Name ===>                              (Required for C,I,R,T)          
                                                                              
Confirm Deletes: YES (Enter YES to require delete confirmation)               
                                                                              
NOTE: To use a table on another system specify the table name as system>table 
      Specify ? as the system name to get a list of all systems.              
                                                                              
                                                                              
                                                                              
 F1=HELP      F2=SPLIT     F3=END       F4=RETURN    F5=RFIND     F6=RCHANGE  
 F7=UP        F8=DOWN      F9=SWAP     F10=LEFT     F11=RIGHT    F12=RETRIEVE 

 

(3) 以下の画面のSelの列にラインコマンドとして、E 編集、D 削除、C コピー 、R リネーム、I 追加を使用出来ます。

RDF Table Editor ------ RDF Table List for System xxxx ------  行  1 -  8 /  8 
    OPTIONS: Browse Copy Delete Edit Free Insert Rename S(edit) Transfer       
  MULTI SYS: MCopy MDelete MTransfer                                           
 Sel Table                       New Table                                     
 ___ COLUMN                                                                    
 ___ SSM_MANAGED_POLS                                                          
 ___ SSM_MANAGED_TBLS                                                          
 ___ SSM_TYPE_TBL                                                              
 ___ SSM_UTYPE_TBL                                                             
___ SSMxxxx3                                                                
___ SSMxxxx3_ACT                                                            
 ___ TABLE                                                                     
******************************* Bottom of data ********************************

Command ===>                                                  Scroll ===> PAGE 

 

Additional Information

Old Japanese Knowledge document ID: JTEC003155

OPS/MVSのその他FAQについては、以下のリンクからご確認ください。

JTEC002336 : CA OPS/MVS FAQ一覧表