After install CABI 7.1.1 on windows, tomcat service will not start
search cancel

After install CABI 7.1.1 on windows, tomcat service will not start

book

Article ID: 254696

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

 

After cleaning up the left over files, the install of jaspersoft completed.

However, the “CA Business Intelligence Tomcat” service is failing to start:

.

Windows could not start the CA Business Intelligence Tomcat on Local computer. For more information, review the System Event Log.

If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1.

....

In windows event viewer, we see this message:

..

à Event viewer, windows logs, system,

Event 7024, service control manager

The CA Business IntelligenceTomcat service terminated with the following service-specific error:

Incorrect function.

………..

from commons-daemon.DATE.log

[2022-11-02 08:38:45] [info]  [ 6712] Commons Daemon procrun (1.1.0.0 64-bit) started

[2022-11-02 08:38:45] [info]  [ 6712] Service cabusinessintelligencetomcat name CA Business Intelligence Tomcat

[2022-11-02 08:38:45] [info]  [ 6712] Service 'cabusinessintelligencetomcat' installed

[2022-11-02 08:38:45] [info]  [ 6712] Commons Daemon procrun finished

[2022-11-02 08:39:21] [info]  [13884] Commons Daemon procrun (1.1.0.0 64-bit) started

[2022-11-02 08:39:22] [info]  [13884] Running 'cabusinessintelligencetomcat' Service...

[2022-11-02 08:39:22] [info]  [  924] Starting service...

[2022-11-02 08:39:22] [error] [  924] Failed creating Java

[2022-11-02 08:39:22] [error] [  924] ServiceStart returned 1

[2022-11-02 08:39:22] [info]  [13884] Run service finished.

[2022-11-02 08:39:22] [info]  [13884] Commons Daemon procrun finished

 

..

 

Environment

Release : SOI 4.2 CU4

CABI windows 7.1.1 on win2019DC

Cause

There was a problem with the tomcat service install.

Resolution

Remove the CABI tomcat service from windows

sc delete cabusinessintelligencetomcat

verify it is gone from the services GUI

re-install the CABI tomcat service:

C:\Program Files\CA\SC\CA Business Intelligence\apache-tomcat\bin

service.bat install

And the tomcat started and is available for login.

Additional Information

Please remember to use the updated reports.exe to integrate CABI with SOI 4.2 CU4.

https://knowledge.broadcom.com/external/article/207157/