AppNeta - Trying to deploy a new V35, and the device does not seem to be configured.
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AppNeta - Trying to deploy a new V35, and the device does not seem to be configured.

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Article ID: 254185

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Updated On:

Products

AppNeta

Issue/Introduction

I'm having trouble configuring my V35, the configuration file didn't take correctly, or the json wasn't loaded.  My IP address seems to be different.

Cause

If your V35 started but appears to be missing your configuration, you may notice:

- The hostname is incorrect - for example, the image below shows an example: vv35-kSJin
- The device is defaulted to using DHCP
- The device is using the default password
- The device is not configured for my organization (missing nis.config). 

How do I resolve these issues?

These settings can easily be remedied by logging into the V35, configuring the IP (if needed) and then accessing the device over the WebUI.

If you open the console settings of your appliance, you may see the similar bootup, and a prompt to log in:

As previously mentioned, If the V35 is not configured correctly - it will default to using DHCP and the default password.
In 13.11.0 and earlier - the default password is: appneta.admin
In 13.12.0 and later, the password is the MAC address in upper case and no colons (for example, 525400E09F76)

Resolution

Please ensure you are running a current software version.  As of November 2025, the current AppNeta release is 16.5.  If you are running a version older then this, we recommend redeploying with a fresh installation.

1.  Log into the monitoring point.

Type in the username:
admin

For a password, please try any password you configured on the appliance.  If it still continues to fail, the default password for a monitoring point is the MAC address, all upper case and no colons.  

For example, if the MAC address is: 00:00:12:34:56:7B 
Then use 00001234567B

If you are having problems determining the MAC for you V35 please have a look at the following articles:
For VMware V35's, see these instructions.
For KVM V35'S, see these instructions.

2.  Once logged in issue
sudo -i

3.  The appliance defaults to use DHCP.  Check for an IP address;

ifconfig eth0

If you need to configure a Static IP, please complete step 4.

4.  Configure a Static IP using curl commands.  In my example below we've used 10.0.0.100/24  - please replace the IPs below with the correct static IP address if needed.

curl -ku admin -X POST "https://localhost/api/v1/interface/" -H "accept: application/json" -H "Content-Type: application/json" -d "{ \"name\": \"eth0\", \"family\": \"inet\", \"method\": \"static\", \"address\": \"10.0.0.100\", \"netmask\": \"255.255.255.0\", \"gateway\": \"10.0.0.1\"}"

When you hit enter, you will be prompted for your password to begin.

5.  Restart networking for the change to take effect. 

sudo systemctl restart networking

6. The appliance should now be online, you can now test for IP connectivity using ping.   Once confirmed working, from a computer in the local network, please attempt to log into the appliance's webui.  In my example:

http://10.0.0.100/

Log in with username:
admin
and the previous password used.

7.  You may now continue configuring the appliance through the Webui:

 

 

 

8.  Check for the Monitoring Points NIS.configuration, consisting of NIS address and Site Key, ect.

9.  If this information is missing, additional steps will need to be made to ensure the V35 is able to connect online.  Please see this following information to configure apply NIS.config + Auth.config through the API.

https://knowledge.broadcom.com/external/article/277015/appneta-missing-authconfig-details-from.html 

Additional Information

There are several commands that can be performed using console.  Please have a look at the following article for additional commands:

https://knowledge.broadcom.com/external/article/254904/appneta-how-do-i-configure-network-sett.html