Lookup plugin stops functioning until you reload plugins.
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Lookup plugin stops functioning until you reload plugins.

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Article ID: 253075

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Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

Lookup plugins work for a period of time, but then fail suddenly.

You have already confirmed that the Issue is resolved after reloading the lookup plugin. 

Environment

Release : 15.8 +

Cause

This issue can be caused by a timeout in the length of time to run the lookup.

For example an LDAP lookup with very large result set can timeout before completion and trigger an unload of the plugin then subsequent lookups may fail. 

Resolution

Modify the Lookup Plugins property file to automatically reload the lookup plugins daily as this may help reduce or eliminate the issue. 

Important Note: Before modifying any file, make a backup/copy of the file as you can then restore the backed up version should you run into any issues.

Navigate to the file located in the following directory on your Enforce server:

Windows: \Program Files\Symantec\DataLossPrevention\EnforceServer\15.8\Protect\config\

Linux: /opt/Symantec/DataLossPrevention/EnforceServer/15.8/Protect/config

Edit the "Plugins.properties" file by opening the file as Administrator and locate the setting named "AttributeLookup.reload" then change its assigned value to "true" from the default "false". 

Save the newly modified file and restart Symantec DLP services as noted in Article ID: 159970 - Restart DLP Enforce services in the correct order

Additional Information

See also 15.8 Troubleshooting lookup plug-ins