PAM: Windows Proxy のアップグレード後にサービス起動後しばらくすると停止してしまう
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PAM: Windows Proxy のアップグレード後にサービス起動後しばらくすると停止してしまう

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Article ID: 250939

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Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Privilegfed Access Manager (以下 PAM) の3.4.3から 4.0.3へのアップグレードに伴い、Windows Proxy のアップグレードを行ったが、サービス ( PAM Proxy ) が起動後すぐに停止してしまう事象が発生。
Windows Proxyは以下の手順でアップグレードしている。
  1. PAM Proxyサービス停止
  2. 旧 Windows Proxy (4.17.x)アンインストール
  3. 旧 PAM フォルダ (C:\cspm_agent) 削除
  4. Windows サーバ再起動
  5. 新 Windows Proxy (4.19.x) インストール
  6. Windows サーバ再起動
  7. PAM Proxy サービス起動

Environment

Release : 4.0

Component : PRIVILEGED ACCESS MANAGEMENT

Cause

要因としては以下の2つが想定されます。

  • PAM サーバとWindows Proxyのバージョンが異なる

PAM サーバと Windows Proxyは対応するバージョンを使用する必要があります。
例えば、以下の組み合わせはサポート対象外となります。

    • PAM.4.0.3 <-> PAM Proxy4.17.x ( ダウンロードファイル名:WindowsProxy-3.4.3.zip)
    • PAM.3.4.3 <-> PAM Proxy4.19.3 ( ダウンロードファイル名:WindowsProxy-4.0.3.zip)
  • 旧バージョンアンインストール後にプロキシ情報の削除が無かったことにより、実際の接続情報がプロキシ側と差異が生じていたたため

    アップグレード時には PAM Proxy のアプリケーションの削除だけでなく、PAM 側の登録情報を一旦削除する必要があります。

  • PAM サーバの443ポートへ疎通ができない。

 

Resolution

以下の手順で Windows Proxy のアップグレードを行ってください。

  1. 対象ホスト側 旧バージョン Windows Proxy の削除
    • PAM Proxy サービスの停止後、コントロールパネルからアンインストールを行ってください。
  2. PAM 側の対象プロキシを削除
    • PAM クライアントでログイン後、認証管理 > ターゲット管理 > プロキシ を選択し、対象のプロキシを削除してください。
  3. 対象ホスト側 新バージョン Windows Proxy のインストール
    • 対応するバージョンのインストーラでインストールを行ってください。

また、PAM サーバアップグレード後でもポート 443 に疎通ができるなどの前提条件を改めてご確認ください。

Additional Information

対象のプロキシ削除に失敗する場合、以下の KB 記事をご参照ください。

Could not delete the old unused proxies.