Unexpected error occurred while logging to enforce console
search cancel

Unexpected error occurred while logging to enforce console

book

Article ID: 249605

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

While logging into enforce console, customer is getting "Unexpected error occurred" message.

Tomcat logs show below errors -

SEVERE [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/ProtectManager].[default]] Servlet.service() for servlet [default] in context with path [/ProtectManager] threw exception
Cause:
com.hazelcast.core.HazelcastInstanceNotActiveException: Hazelcast instance is not active!com.hazelcast.core.HazelcastInstanceNotActiveException: Hazelcast instance is not active! 

Environment

DLP 15.8 and later

Cause

While we do not see any out of memory errors in the localhost log, this error is caused due to less java heap size for the DLP Manager service. 

Resolution

Increase the java heap size of the DLP manager service. 

 

1. On Enforce Server, Edit the file "SymantecDLPManager.conf"

Linux: 

/opt/Symantec/DataLossPrevention/EnforceServer/Services

Windows: 

C:\Program Files\Symantec\DataLossPrevention\EnforceServer\Services

Note: Ensure you take a backup of the "SymantecDLPManager.conf" file before making any changes. 

 

2. Default value for Java Heap size in "SymantecDLPManager.conf":

# Initial Java Heap Size (in MB)

wrapper.java.initmemory = 1378

# Maximum Java Heap Size (in MB)

wrapper.java.maxmemory = 2048

 

New values that needs to be configured:

# Initial Java Heap Size (in MB)

wrapper.java.initmemory = 2048

# Maximum Java Heap Size (in MB)

wrapper.java.maxmemory = 4096

 

3. After making the above changes, Restart all DLP services in order. 

Restart DLP Enforce services in the correct order

4. Now, you should be able to login to enforce console without any issue.