Some vmware probe VMs no longer show data in Metric Viewer
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Some vmware probe VMs no longer show data in Metric Viewer

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Article ID: 245031

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We have in our environment several Vmware probes configured with MCS. Everything is working fine except for 2 devices/vm's/hosts that are showing the following behaviour:

These devices do not have any recent QOS in the Database. 

The devices show duplicated entries in the CM_computer_system tables for each device and display NO IP Addresses. 

 

 

Additional notes: 

These vm's could not be found in the AC - System read-only trees in the VMWARE probe configuration below the Vcenter.

When searching the inventory for the IP of the affected server we can see that the VM correspondent to IP is actually assigned to another VM's name.

Other devices has correct active QOS being stored.

Environment

Release : DX UIM 20.4.* / 23.4

Component : Vmware 7.x

Cause

Some VM's were decommissioned and the IP address was assigned to some other VMs

Resolution

As the devices were removed from the Vcenter and IP assigned to an other device there is a mismatch in the discovery between these devices. 

We shall try to remove them (all devices) from the inventory and let the discovery try to correlate the active devices again.




Steps to follow: 

 

1. Stop the vwmare probe

2. go to the inventory and search for the affected device: 

"VM_NAME"

Select it from the and then go to the 3 dot menu on the right and select "Delete Devices"

3. UNtick Prevent Rediscovery, Acknowledge alarms, Delete measures 

4. Repeat point 2. and 3. for  all affected VMs

5. Clear niscache on the robot where vmware probe is installed. (follow the procedure below)

How to clear the niscache on an individual robot (broadcom.com)

(the procedure makes the robot restart too)

6. Start the vmware probe.

7. Restart the discovery_server

 

Wait for 15/20 minutes, then check again the inventory and see if the issue is resolved