ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Unable to import IP Addresses to a Filter from a CSV file

book

Article ID: 240173

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

We have a customer that is trying to add "IP Addresses" to a filter (under the Import Resource List window) as a Computer Resource type.

They are using a ".csv" file to upload data (IP addresses in this case).

  

When the import occurs, they only get a message like this (they tried just with one IP Address in a simple .CSV file):

0 of the 0 resources found in the file were successfully imported. If any resources failed to import, it is likely that they have not yet been discovered. Unable to cast object of type 'System.DBNull' to type 'System.String'.
   [System.InvalidCastException @ Altiris.Web.NS]
   at Altiris.NS.UI.NSResourcePickerControl.OnImportCompleted(Object sender, EventArgs e)

There are around 600 IP addresses in total and what they have observed is that this issue is being observed for 50 or so IPs.
They have checked and verified the filter created which is a basic filter with query mode as none and the import resources list selected as computer.

Their additional observation is that all the IPs are discovered / visible under All computers. The IP addresses that are not importing already exist in the SMP Console under Manage>Computers from an existing Computers.

Also, they tried importing the data via hostname but that did not work.
If they add the IPs manually to the filter, it is getting added (no using a CSV file).

 

Cause

Known issue. Our Dev team fixed an issue with "no name" situation for matched IP to resource import.

Environment

ITMS 8.6 RU1, RU2

Resolution

This issue has been reported to Broadcom Development team. A fix is currently targeted for ITMS 8.6 RU3 release.