search cancel

AIOps - dxi_update_ingress_secret.sh incorrectly reports that "Tls is not enabled"

book

Article ID: 237362

calendar_today

Updated On:

Products

DX Operational Intelligence

Issue/Introduction

Introduction:

The dxi_update_ingress_secret.sh script enables you to update the expired TLS certificates and keys that you defined in the Kubernetes secrets for the DX Platform ingresses. For more information, see the Update the TLS Certificates section.

Problem description:

When running dxi_update_ingress_secret.sh to change the secret tls it returns a message indicating that tls is not enabled

[[email protected] tools]# ./dxi_update_ingress_secret.sh -n=dxi -s=tivibu-2022 -o=tls-secret
[VALIDATE] Checking if namespace dxi is present ...
[VALIDATE] Tls is not enabled, no need to update certificates

 

Cause

The problem is related to defect DE530938

Environment

DX Platform 21.3.1

Resolution

Solution: none, defect will be fixed in next on-premise release.

Workaround: use attached fixed dxi_update_ingress_secret.sh script : 

Additional Information

https://knowledge.broadcom.com/external/article/190815/aiops-troubleshooting-common-issues-and.html

Attachments

1647864789294__dxi_update_ingress_secret.sh get_app