The process AexNSagent.exe is causing high CPU utilization and high memory usage ...
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The process AexNSagent.exe is causing high CPU utilization and high memory usage ...

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Article ID: 237049

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

High CPU and memory usage caused by the AexNSagent.exe process is affecting several systems.  IT Management Suite (ITMS) 8.x is installed as are the point fixes from the following KB articles:

234726 Client Machines get disconnected from task server registration. If we restart Task services or reboot, the client gets registered.

215121 CUMULATIVE POST ITMS 8.6 RTM (GA) POINT FIXES

221269 CUMULATIVE POST ITMS 8.6 RU1 POINT FIXES

235538 CUMULATIVE POST ITMS 8.6 RU2 POINT FIXES

249427 CUMULATIVE POST ITMS 8.6 RU3 POINT FIXES

261271 CUMULATIVE POST ITMS 8.7 RTM POINT FIXES

273903 CUMULATIVE POST ITMS 8.7.1 POINT FIXES

366939 CUMULATIVE POST ITMS 8.7.2 POINT FIXES

382575  CUMULATIVE POST ITMS 8.7.3 POINT FIXES

The agent.log files didn't show much useful information.

The Event Viewer logs included the following:

Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: AeXNSAgent.exe (3020) consumed 13534584832 bytes, oracle.exe (4348) consumed 3736662016 bytes, and oracle.exe (3812) consumed 3706085376 bytes.

Environment

ITMS 8.x

Cause

Appears to have been some corruption in the Symantec Management Agent (Altiris Agent)

Resolution

Reinstalling the Symantec Management Agent resolved this issue.

Uninstall the Symantec Management Agent.

Open a command prompt and navigate to the folder (by default) 'C:\Program Files\Altiris\Altiris Agent' and execute the following command: 'AeXNSAgent.exe /uninstall'

This will remove the Agent, or you can use the uninstall agent policy:

Install the correct version of the Agent.

To install SMA, please refer to:

Methods for Installing the Symantec Management Agent