search cancel

AIOps 21.3.1 - AUTOMIC Policies are not working, remediation workflows are not executed

book

Article ID: 235168

calendar_today

Updated On:

Products

DX Operational Intelligence DX Application Performance Management

Issue/Introduction

AUTOMIC has successfully been configured, we confirmed manual execution of AUTOMC remediation is working as expected however, execution via a Policy is not working

Here are a summary of the steps taken: 

1) From DX OI UI, Click on "+Policy"

2) Give a Name + reused the existing prepopulated filters + click Save

 

3) From DX OI UI: confirmed that new Alarms are created

4) From AUTOMIC UI, confirmed that workflow is not executed

 

Cause

This problem is related to defect # DE528974 

 

Environment

DX OI 21.3 + AUTOMATION INTEGRATION

Resolution

We plan to fix this issue in the next DX Platform on-premise release


DE528974 DEFECT DESCRIPTION

ISSUE #1: The filter defined from the OI page and coming to the Policy page is not correct hence the filter will never match the expected alarms

WORKAROUND:

Do not use the "+Policy" option from DX OI, instead use the Launch Pad > Settings > Policies option


ISSUE #2: When navigating to the policy page from the OI page, the alarms filter attributes are not selected correctly based on alarm type. 

WORKAROUND:

Switch to a different alarm type, for example to "Service Alarms" and then back to "All Alarms" to be able to see all the correct filter attributes.

ISSUE#3. AUTOMIC notification works ONLY with an active channel, however it should work without a channel defined

WORKAROUND:

Create any dummy channel and link it with the AUTOMIC policy(ies) for the AUTOMIC remediation to be triggered

Additional Information

https://knowledge.broadcom.com/external/article/190815/aiops-troubleshooting-common-issues-and.html#mcetoc_1f7qcopf91uk

Attachments