Windows ADK Import to Deployment Solution taking hours without indication of progress
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Windows ADK Import to Deployment Solution taking hours without indication of progress

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Article ID: 233388

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Updated On:

Products

Deployment Solution

Issue/Introduction

It is noticed after importing a Windows ADK to Deployment Solution (Settings > Deployment > Preboot Configurations) the console status of "Deployment Solution is importing the Windows ADK to use WinPE as a preboot environment" is still showing after waiting hours for the import to finish. It is also noticed that the hour glass indicating the upload is there long after the 10-15 min interval has passed as seen here:

Environment

DS 8.6

Cause

Possibly a bad installation of Windows ADK

Resolution

Ensure the Windows ADK was installed correctly. The latest versions of WinPE 10 and 11 require two downloads and two installs:

  • Windows ADK
  • Windows PE add-on for the Windows ADK

They must be installed by a user with administrator rights and with UAC turned all the way down. The installation can also be problematic with antivirus installed and it is recommended disabling this temporarily while the ADK installs. This installation requires the server to have internet access. If the server does not have internet access, an offline installer package will need to be created off-box. Both installs should be installed in the default location.

Since Bootwiz uses the temp directory to build the WAIK folder it is also suggest that any Group Policies that are built to protect writing against the Windows\Temp directory be temporarily disabled (not enforced).

Once both ADK installs are properly installed (this may require an uninstall/reinstall), check the PrebootOS.ini file to verify if the version of WinPE you attempted to import is listed as "Installed=True". If it is listed as "Installed=True", change this to "Installed=False" as outlined in the KB article Need to Re-Import Windows Preboot Operating Systems Into Deployment Solution 8.x

At this point Broadcom/Symantec recommends attempting to manually import the ADK to bootwiz.exe as this will provide an error message quickly if the next import fails.

To do this, navigate to %ProgramFiles%\Altiris\Deployment\BDC\bootwiz\BootWiz.exe on the Notification Server/SMP.

Run BootWiz.exe as administrator. 

The first Window may prompt you to import a preboot OS. If it doesn't, navigate to Tools > Install Pre-Boot Operating Systems

Select the Pre-boot OS version you installed from the list, then in the location section at the bottom, select the radio button for "Pre-installed WAIK" and enter the path as follows:

Later versions of WinPE 11 may use a different path but as of 1/28/22, C:\Program Files (x86)\Windows Kits\10 is the default path for the latest ADK (even for WinPE 11).

Import both the x86 and x64 versions keeping the path the same on both.

Once imported, verify the PrebootOS.ini file is changed to Installed=True and that the console no longer indicates it is importing.

At this point you should be able to build a preboot config with the newly installed/imported ADK.

If you are still seeing issues, contact Broadcom Support.