How to fix "Invalid device credentials" in Management Center
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How to fix "Invalid device credentials" in Management Center

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Article ID: 231772

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Management Center

Issue/Introduction

Management Center(MC)で管理している機器の内、1台のContent Analysis System(CAS)に「Invalid device credentials」というErrors and Warningsが出ています。
CASへログインして、System Statusを確認するとOKとなっており、UtilitiesタブのOnboard Diagnosticsも全てOKとなっています。

MCでCASの接続情報をConnection Parametersから確認するとSuccessfulと表示されており、Reconnectボタンを押してもSuccessfulの状況です。
UsernameとPasswordに問題が無いのに、なぜStatusタブは「Invalid device credentials」と表示されているのでしょうか?
どのようにすれば解消できるでしょうか?

Environment

Release : 3.1.3.1

Component : Connection Parameters

Cause

CASで、アカウントが過去に一度ロックアウトされたことは無いでしょうか?
MCで設定しているアカウントが、Password policyなどで一度ロックアウトされると、MC上からもCASへアクセスが不可となり、
「Invalid device credentials」Stateとなります。

その後、CAS側でアカウントのロックが解除されても、「Invalid device credentials」Stateは維持され、
MCのAdministratorが、CASのStateを上書きするまで、アカウント情報が正しいにもかかわらず、Backup Jobなども
「Invalid device credentials」で失敗するようになります。

Resolution

本事象の解消方法は、MC側でCas Stateの上書きが必要となります。
簡単な上書き方法は、CASの事前定義されている「admin」アカウントで実施頂けます。
※adminアカウントで事象が発生している場合は、別のアカウントを御利用ください。

【MC側でCas Stateの上書き方法】
1.MCへログインして「Connection Parameters」へ移動して、CASの事前定義アカウント「admin」を使って一度接続を成功させ、saveボタンを押下します。
  →この作業を行うと、Status画面に表示されている「Invalid device credentials」はFixされます。
2.再度「Connection Parameters」へ移動して、過去に設定していたアカウントへ戻して頂き、Saveボタンをクリックします。

Additional Information

CASのアカウントロックの状況は、CASのCLIより以下のコマンドで御確認頂けます。
アカウントがロックされていると、「Connection Parameters」からの御確認は「Invalid device credentials」で失敗いたしますので、
御確認頂いた際は、ロックされていない状況が御確認頂けるはずです。

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CAS(config)# authentication local-lockout view
Lockout parameters:
  Max failed attempts:         3
  Lockout duration (seconds):  900
  Reset interval (seconds):    900

User:  admin
  0 failed attempt(s) (of 3 allowed)
  61.75 seconds since last attempt or reset

User:  testaccount
  0 failed attempt(s) (of 3 allowed)
  9.09 seconds since last attempt or reset

CAS(config)#
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English version of this article can be found in Article 233857