Memory related error messages in Encryption Management Server Mail Log
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Memory related error messages in Encryption Management Server Mail Log

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Article ID: 231631

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Updated On:

Products

Gateway Email Encryption Encryption Management Server

Issue/Introduction

Under Reporting / Logs / Mail log in the Encryption Management Server administration console, there are errors referring to memory and messages may not be sent or received. The errors may contain text such as:

  • Cannot allocate memory
  • unable to determine error -- out of memory?

Environment

Symantec Encryption Management Server 10.5 and above.

Cause

Memory fragmentation has occurred. This is generally the result of the Encryption Management Server mail proxy service processing very high volumes of email and / or running for an extended period (hundreds of days for example) without being restarted.

Resolution

To workaround this issue, navigate to System / General Settings in the administration console and click on the Restart Services button. This will restart all services, including the mail proxy.

To restart just the mail proxy service, ssh to Encryption Management Server and enter this command:

pgpsysconf --restart pgpuniversal

If memory related errors occur regularly, consider restarting the mail proxy service daily or weekly. Please open a technical support case for assistance in doing this.