Unable to create a new Software Update Policy Task. Staying on "Task is being initialized" status
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Unable to create a new Software Update Policy Task. Staying on "Task is being initialized" status

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Article ID: 231299

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Updated On:

Products

IT Management Suite Patch Management Solution

Issue/Introduction

The customer is trying to create a new "Software Update Policy" task to distribute some patch packages. 

When the "Creating Software Update Policy" window appears, the status stays in "Task is being initialized..." indefinitely. 

The NS logs just show log entries like these ones:

Created a task 'SLO test policy DROPBOX-211221'.
-----------------------------------------------------------------------------------------------------
Date: 12/28/2021 7:24:45 AM, Tick Count: 15071062 (04:11:11.0620000), Size: 349 B
Process: w3wp (4808), Thread ID: 328, Module: Altiris.PatchManagementCore.dll
Priority: 4, Source: Altiris.PatchManagementCore.Tasks.Server.SoftwareUpdateDistributionTask.CreateInstance

 

Starting task instance 'SLO test policy DROPBOX-211221' (ecea1bbb-98fb-4f70-9037-6ff838847bd9) from 'Distribute Software Updates' (99b6a96a-f0a2-40fa-88bb-9ddfa97b4ddf, 9480a600-4610-4997-a25d-147f5c606b7b)
-----------------------------------------------------------------------------------------------------
Date: 12/28/2021 7:24:45 AM, Tick Count: 15071218 (04:11:11.2180000), Size: 431 B
Process: AtrsHost (5520), Thread ID: 176, Module: AtrsHost.exe
Priority: 4, Source: ServerTaskExecutionThread

And then just loops on messages like these ones:

Entry 1:

Resuming task instance 'SLO test policy DROPBOX-211221' (ecea1bbb-98fb-4f70-9037-6ff838847bd9), 12/28/2021 8:48:34 AM
-----------------------------------------------------------------------------------------------------
Date: 12/28/2021 8:54:30 AM, Tick Count: 1926234 (00:32:06.2340000), Size: 341 B
Process: AtrsHost (9416), Thread ID: 116, Module: AtrsHost.exe
Priority: 4, Source: ServerTaskExecutionThread

Entry 2:

Task is being initialized...
-----------------------------------------------------------------------------------------------------
Date: 12/28/2021 8:54:30 AM, Tick Count: 1926234 (00:32:06.2340000), Size: 270 B
Process: AtrsHost (9416), Thread ID: 116, Module: AtrsHost.exe
Priority: 4, Source: PMC:SoftwareUpdateDistributionTask.Progress

Entry 3:

Another instance is running, task put to sleep for: 00:00:20
-----------------------------------------------------------------------------------------------------
Date: 12/28/2021 8:54:30 AM, Tick Count: 1926250 (00:32:06.2500000), Size: 302 B
Process: AtrsHost (9416), Thread ID: 116, Module: AtrsHost.exe
Priority: 4, Source: PMC:SoftwareUpdateDistributionTask.Progress

Environment

ITMS 8.5, 8.6, 8.7

Cause

Possible SQL Server performance issues or hung Altiris Services

Resolution

There have been issues in the past where other Software Update Policy Tasks are just hung (due to issues with the SQL Server or just services not responding in a timely fashion). 

Try the following:

  1. Go to Manage>Jobs and Tasks>System Jobs and Tasks>Software>Patch Management>Distribute Software Updates



  2. Check that there are no tasks running for a long time. If so, select it/them and right-click>Stop
  3. If there are no tasks on this page in a running state, restart the Altiris Service, Altiris Client Task Data Loader, and Altiris Object Host Service.
  4. If restarting the services didn't help, check for other tasks running in your environment and try to stop them. Please refer to the following articles:
    162782 "Change status of hung tasks showing as currently running"
    171824 "Report to show currently running tasks"