How to Change the Status of Hung Tasks Showing as Currently Running
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How to Change the Status of Hung Tasks Showing as Currently Running

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Article ID: 162782

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Updated On:

Products

IT Management Suite

Issue/Introduction

The currently running task reports show tasks that have been running for many days or months. To change the task status from running to Failed or Completed, use the attached SQL statement.  This will cause the tasks to drop off the Currently Running Task report.

None recorded.

Environment

ITMS 8.6+

Cause

There are multiple reasons a task might show as currently running but have timed out or stopped due to conflicts. For more information on task status issues, see KB 257688 

Resolution

To change the task status from Running to Failed or Completed, see the below SQL query.  The query searches for tasks that have been running longer than 7 days and changes the status to either 2 = Completed or 3 = Failed. 

For 8.6 and later

On recent releases, it is no longer needed for customers to perform SQL queries to drop task instances in case those are hung. A customer can use the default mechanism to purge the required amount of task instances, task versions, etc. under Settings>All Settings>Notification Server>Task Settings:


When purging for task instances is started, then there is a set of stored procedures will be executed, like tmDeleteOrpanedTaskInstances, tmDeleteOrpanedTaskInstanceParents, tmDeleteOrpanedTaskOutputPropertyValue, and tmDeleteOrpanedTaskInstanceResultSummaries.

 

If the Customer is logged in to SMP Console using the default "Symantec Administrators" role, then on any opened task, there is a link to "view recent tasks". From this view, the Customer can multi-select and delete/stop unnecessary task instances