Error in SIM during Install Readiness Check: HierarchyReplicationIRC failure message.
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Error in SIM during Install Readiness Check: HierarchyReplicationIRC failure message.

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Article ID: 219800

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

You are trying to upgrade. When SIM (Symantec Installation Manager) is doing the IRC (Install Readiness Check) process, it fails during HierarchyReplicationIRC validation:

Entry 1:

RunInstallReadinessCheck - exception during execution.

Object reference not set to an instance of an object.

   [System.NullReferenceException @ cjb2oi5f]
   at InstallReadinessChecks.HierarchyReplicationIRC.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)
   at Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()


-----------------------------------------------------------------------------------------------------
Date: 6/23/2021 3:25:01 PM, Tick Count: 4480625 (01:14:40.6250000), Size: 1.73 KB
Process: SymantecInstallationManager (12124), Thread ID: 23, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.InstallReadinessCheckRunner.RunCheck

Entry 2:

PerformInstallReadinessCheck - InstallReadinessCheckException occurred while executing test HierarchyReplicationIRC
Exception occurred while executing RunInstallReadinessCheck
   [Symantec.Installation.InstallReadinessCheckException @ SymantecInstallationManager]
   於 Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)
   於 Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()

Object reference not set to an instance of an object.
   [System.NullReferenceException @ cjb2oi5f]
   at InstallReadinessChecks.HierarchyReplicationIRC.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()


-----------------------------------------------------------------------------------------------------
Date: 6/23/2021 3:25:01 PM, Tick Count: 4480625 (01:14:40.6250000), Size: 2.07 KB
Process: SymantecInstallationManager (12124), Thread ID: 23, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks

 

Entry 3:

Install Readiness Check '' Failure: HierarchyReplicationIRC Installation Readiness Check, Result 'failed'
-----------------------------------------------------------------------------------------------------
Date: 6/23/2021 3:25:53 PM, Tick Count: 4532968 (01:15:32.9680000), Size: 385 B
Process: SymantecInstallationManager (12124), Thread ID: 23, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Automation.Output.ReportError

Environment

ITMS 8.x

Cause

Incorrect entry in the registry

Resolution

Verify the following:

1. Make sure you don't have a hierarchy setup (SMP Console>Notification Server> Hierarchy

2. If you don't have a Hierarchy, check under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\ for "HierarchyReplicationEnabled" regkey. It should be set to "False".
Also, check for "NTierHierarchyEnabled" regkey. It should be set to "False".

Note:

If everything looks fine and no other indication of Hierarchy is setup, Enable the Next Button for the Install Readiness Check: https://knowledge.broadcom.com/external/article/156257/enable-the-next-button-for-the-install-r.html