Endpoint Protection Manager stops working until service restart
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Endpoint Protection Manager stops working until service restart

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Article ID: 219553

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Symantec Endpoint Protection Manager (SEPM) stops working or hangs at login until you restart the SEPM service.  Content LiveUpdate updates/publishing may be the first task to stop working.

Environment

Release: 14.3 RU2, RU3, RU4

Cause

Deadlock or timeout situation on the database.

 

What is Read Committed Snapshot ?

The idea behind read Committed Snapshot Isolation is the following: instead of locking a record during the reading phase with a Shared Lock, SQL Server will transparently return you the old committed record version from the Version Store. The Version Store is stored in TempDB.

 

Resolution

This issue is fixed in Symantec Endpoint Protection Manager (SEPM) 14.3.6.0 (RU6). For information on how to obtain the latest build of SEP, see Download Symantec software, tools, and patches.

Workaround:

1. Take a backup of SEPM Database
2. Stop all SEPM Services
3. Open SQL Server Management Studio and run the following query.  Replace sepmdbname with the name of your SEPM Database.

ALTER DATABASE <sepmdbname> SET READ_COMMITTED_SNAPSHOT on WITH ROLLBACK IMMEDIATE

4. Start all SEPM services

Also add the following to the conf.properties file (C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\etc\conf.properties), to prevent this setting from being changed on upgrade.

scm.upgrade.disable.database.snapshot=false

 

 

Additional Information

ESCRT-7381