VIP Enterprise Gateway Self-Service (SSP) IdP, MyVIP IdP, or LDAP Sync service will not start. Fails with network or time error.
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VIP Enterprise Gateway Self-Service (SSP) IdP, MyVIP IdP, or LDAP Sync service will not start. Fails with network or time error.

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Article ID: 212584

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Updated On:

Products

VIP Service

Issue/Introduction

VIP Self-Service Portal or MyVIP Enterprise IdP Service will not start. Error "There may be a problem with the network connectivity of system time. Verify the network connectivity and make sure VIP Enterprise Gateway service time is set correctly and try again". 

Cause

- Incorrect local server time
- Network connectivity to the VIP Cloud

Resolution

  • Run the VIP Diagnostic Tool from the VIP EG server and observe the time in the logs\VIPDiagnotic.log.  The local VIP EG server time (converted to UTC) cannot deviate by more than 5 minutes from time fetched from the VIP Cloud. 

    Example of VIP serverTime UTC 1607746669000 returned from the VIP Cloud (in epoch time).
    If the VIP Cloud time is not within 5 minutes of the local server time and timezone, adjust accordingly. 
    AUDIT "2020-12-11 22:17:49.494 GMT-0600" "[VipDiagnostic] Test - Server Time Check"
    AUDIT "2020-12-11 22:17:49.822 GMT-0600" "[VipDiagnostic:testServerTimeCheck] Successfully fetched server time. serverTime: 1607746669000"
    INFO  "2020-12-11 22:17:49.822 GMT-0600" "[VipDiagnostic:testServerTimeCheck] Local time ahead of server time"
    AUDIT "2020-12-11 22:17:49.822 GMT-0600" "[VipDiagnostic:testServerTimeCheck] Time difference between serverTime and localTime is 0 seconds"
    INFO  "2020-12-11 22:17:49.822 GMT-0600" "[VipDiagnostic:testServerTimeCheck] Server time and local time are in sync."
    AUDIT "2020-12-11 22:17:50.119 GMT-0600" "[VipDiagnostic] Test - Server Time Check: [ Success ]"
    Example of VIP serverTime 0 returned from the VIP Cloud, indicating the server could not reach or resolve https://userservices.vip.symantec.com.
    To resolve this, whitelist this and other VIP Cloud URLS See: Globally Balanced URLS Default ports and protocols 


  • If this is a fresh VIP EG installation or settings were recently imported: Open the VIP Enterprise Gateway console, click Settings, then Healthcheck settings. If this service is enabled, edit the settings, increase the polling interval by 1 second, save the settings, and then restart the Healthcheck service. This 'resets' the Healthcheck service. If successful, the 1-second change can be rolled.