Symantec IT Management Suite 8.6 unsupported solution upgrade issues

book

Article ID: 210241

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

When you upgrade any of your products, the Symantec Management Platform is also upgraded.  Likewise, when you upgrade the platform, you must also upgrade your solutions to a version that the platform version supports. This behavior prevents problems from occurring from mismatched versions between the products and the platform.

However, there are products that you can install outside of the traditional ITMS family of suites. These products may not support the current 8.6 version of the platform.

If you have a product installed that does not support the 8.6 platform, when you use Symantec Installation Manager (SIM) to upgrade to the 8.6 platform, then your product is automatically uninstalled. SIM must remove the product in order to complete the upgrade. SIM provides a warning message to inform you that the product will be removed.

If you intend to install a product that does not support the 8.6 version of the platform and you attempt to use the traditional method in SIM, then the product is installed but SIM also installs the latest 8.6 version of the platform (which is not supported by the product). This could potentially cause problems with the product.

To workaround this situation, when you select "Install New Products" in SIM, you must first enable the option "Show all Versions". Then select the product that you want to install. SIM will then automatically choose the appropriate version of the platform.

If you already have the 8.6 version of the platform and then you later decide that you want to install a product that does not yet support the 8.6 version, SIM will not prevent you from installing this version but this may result in unexpected behavior. 

Environment

ITMS 8.6

Resolution

 

As of the date of this article, please be aware of the status of the of the following components with regards to compatibility with the 8.6 platform:

Component/module

Comment

Altiris IT Analytics Symantec Endpoint Protection Pack 

Altiris IT Analytics Symantec Endpoint Protection Pack Languages 

ITA SEP pack should be uninstalled, then will be possible to upgrade to 8.5 or 8.6.
KB 185015

Altiris IT Analytics Data Loss Protection Pack 

ITA DLP pack should be uninstalled, then will be possible to upgrade to 8.5 or 8.6.
KB 185015

Symantec Unified Endpoint Protection (SUEP) Bridge solution

It will be hidden in SMP Console after upgrade from ITMS 8.1 RU7 or 8.5 RU4 to ITMS 8.6 release.

A customer can make it visible back, using "Item visibility" page from SMP Console (Settings>Notification Server>Internals>Item Visibility>Security Cloud Connector)

"ULM Agent" 8.6
"Inventory Solution Agent" 8.6
"Software Management Solution Agent" 8.6
"Monitor Agent" 8.6 
All these components will not be available for "AIX" & "HP-UX" systems In ITMS 8.6 release
"Workspace Virtualization" agent packages & rollout policies  These will not be available after upgrade from 8.1 RU7 to 8.5 or 8.6.
This product is end of life many years ago. See KB 150504
"Workspace Virtualization, Streaming End Of Life Statement (EOL)"
CentOS 6.x system Support These CentOS devices can't be patched via Patch Management Solution because vendor stopped CentOS 6 support and there is no patch updates available.
   
   

For information specific to 3rd-party solutions, please contact the corresponding vendor.