Datamart Rollup job error :'Determine current fiscal period:'
search cancel

Datamart Rollup job error :'Determine current fiscal period:'

book

Article ID: 205956

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

We have been receiving at least 6 of these job messages since January 1st, 2023, and it looks like the scheduled jobs for "Job Datamart Rollup - Time Facts and Time Summary" have failed to run in production.

App logs:

ERROR 2023-01-23 00:10:00,937 [Dispatch Datamart Rollup - Time Facts and Time Summary : bg@cppm9012 (tenant=clarity)] niku.njs (clarity:clarity user:clarity session:Datamart Rollup - Time Facts and Time Summary) Error executing job: 5158044
com.niku.union.persistence.PersistenceException: 
SQL error code: 0
Error message: ERROR: Error in CMN_JOB_DATAMART_ROLLUP_SP -  Error in NBI_EXTRACT_TF_TS_SP - :Determine current fiscal period: query returned no rows
  Where: PL/pgSQL function cmn_job_datamart_rollup_sp(bigint,bigint) line 72 at RAISE
Executed:
call CMN_JOB_DATAMART_ROLLUP_SP ( 18329186, 5076225) 

Environment

Release : 15.9.x, 16.x 

Component : CA PPM SAAS DATAMART

Cause

There are no active fiscal time periods for 2023. 

Resolution

  1. Navigate to Administration, Finance Management: Setup, Entities
  2. Select your Entity, Fiscal Time Periods tab
  3. Set-up the time periods for 2023 and mark them 'Active'
  4. A quick Review the configuration on the Administration> Datamart Settings page for both the Datamart and the Datamart Rollup options. 
  5. Run 'Datamart Extraction' job with no parameters checked
  6. Run 'Datamart Rollup - Time Facts and Time Summary'  

Additional Information