CADS001E CADDSNT already active error initializing the CA Dispatch SVC
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CADS001E CADDSNT already active error initializing the CA Dispatch SVC

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Article ID: 200920

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Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

Customer ran CAS9/CAIRIM to initialize the CA Dispatch SVC but the job returned the following errors:

CADS001E CADDSNT already active                                             
CAS9140E - Init error: CADISPATCH Ver DSB7, Init routine RC=000C  

Is there a way to FORCE a re-initialization of the CA Dispatch SVC?

Environment

z/OS, Dispatch, CAS9, CAIRIM

Cause

This "already active" error occurs if the CA Dispatch SVC and CADDSPLx related modules have already been initialized and are in memory on the system.

Resolution

If your intention is to run a custom or special CAS9/CAIRIM in order to FORCE a re-initialization of the CA Dispatch SVC, then all you would need to do to avoid this "already initialized" error would be to change the VERSION parameter specified on the CA Dispatch initialization statement.

Example:

- Change: PRODUCT(CA-DISPATCH) VERSION(DSB7) INIT(DSINIT)

- To:          PRODUCT(CA-DISPATCH) VERSION(DSB6) INIT(DSINIT)

Changing the VERSION in the CA Dispatch initialization statement will in deed FORCE a reinitialization of the Dispatch SVC. However, it will not force a reload of the CADDSPLx related modules into memory.

If you were in a situation where you had to force reinitialization of the CA Dispatch SVC "AND" a reload of the CADDSPLx related modules, you would need to perform the SVCREDO procedure. (Or, you could also IPL).


The process know as the "SVCREDO procedure" is documented in the following Knowledge Article :

Article Id: 10968 Title - Reinitializing the CA Dispatch SVC. (Also known as the SVCREDO procedure).