AIOps - Unable to login due to password expiration
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AIOps - Unable to login due to password expiration

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Article ID: 194529

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Updated On:

Products

DX Operational Intelligence DX Application Performance Management CA App Experience Analytics

Issue/Introduction

Unable to login, dxiportal login reports "Failed to login. Verify that user ID and password are correct"

Environment

DX Platform 2x

Cause

By default password expires after 180 days

 

How verify the condition

1) Monitor the dxi-adminui log

kubectl get pods -n<namespace> | grep dxi-adminui
kubectl exec -it <dxi-adminui-pod> bash -n<namespace>
cd logs
tail -f *.log

2) Attempt to login

3) in the logs you should see the "Password has expired" message

 

How to check default setting?

a) obtain the postgres pod name

kubectl get pods -n<namespace> | grep postgres

b) exec postgres pod

kubectl exec -it <postgres-pod> -n<namespace> bash

 
c) connect to aoplatform database

psql -U aopuser -d aoplatform

 

d) Check default validity Period:

select * from aradminpwdpolicy ;

orgname         | minpasswordlength | maxpasswordlength | minnumericchars | minalphachars | minspecialchars | strikecount | allowedsplchars | isglobal | validityperiod |
 passwordhistcount | isallowall
------------------------+-------------------+-------------------+-----------------+---------------+-----------------+-------------+-----------------+----------+----------------+
-------------------+------------
 --globalorganization-- |                 6 |                25 |               1 |             4 |               1 |           5 |     | Y        |            180 |
                 3 | N
 

Resolution

If the affected user is the TENANT administrator:

Login to http://<apmservices-gateway>/dxiportal/#/dxiportal/login as MASTERADMIN

Go to Tenant Services, 

Locate your Tenant, click "Configure"

Change the password

 

b) For any other user, login to the Tenant as Tenant administrator and change the password from "Manage User" option as below

Login to http://<apmservices-gateway>/dxiportal/#/dxiportal/login as the TENANT administrator user

Go to "USER-MANAGEMENT"

Locate the affected user

Update the password

Additional Information

DX AIOPs - Troubleshooting, Common Issues and Best Practices
https://knowledge.broadcom.com/external/article/190815