CA Spectrum - NCM capture is not taking all lines but it is showing as successful
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CA Spectrum - NCM capture is not taking all lines but it is showing as successful

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Article ID: 189753

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Updated On:

Products

CA Spectrum

Issue/Introduction

While taking the NCM capture of a device (Eg : fortigate firewalls), the configuration backup is showing successful but it does not have all lines.

Environment

Release : 10.4 and Up

Component : Spectrum Applications

Cause

Because we start the communication/transfer, then it gets severed.
Spectrum/NCM is not going to stop until its told to do so.  The network is running this as our request was answered and data is coming in - its just coming in incomplete.

Its Indicating its successful because we are receiving a response.  Spectrum does not know what a full configuration looks like, only what the device is telling us.

Resolution

If it is gathering just some of the configuration its a network issue, NOT a Spectrum issue.
The connection from the device to getting cut off so need to check with Network team.

 

If the transfer is TFTP, The following timeout parameters can be added to the $SPECROOT/SS/.vnmrc file:

 

ncm_tftp_wait=2

ncm_startup_wait=2

Restart the SpectroSERVER after making the changes to the .vnmrc file. 

Additional Information

NCM Troubleshooting: https://knowledge.broadcom.com/external/article?articleId=185362