The Clarity application is unusable. Any update done on the application is shown as processing but there is no end to it.
Some symptoms users may report:
When you try to update tasks, create status reports, update records (e.g. Timesheets, Ideas and Projects) we are unable to save.
The save icon spins and does not save.
This is occurring for all users, and in multiple modules
Slow Performance in login or any page navigation.
Unable to login
Application is not working / Updates made in application not going through
DB lock message when trying to update an attribute.
Page takes a long time to load / running slow
Pages take several minutes or longer to load
The above may be reported in Production or non production environments (such as Test or Development)
Environment
Release : All Supported Releases
Cause
This can be caused by a Database (DB) issue including DB level row locks / if there are blocking sessions on the database.
Resolution
On Premise customers:
Contact your DBA to identify Database level locks / blocking sessions and ask them to clear them
If using Oracle:
Check with Oracle on any related issues that may be causing the issue where a patch may be required from Oracle
If there is a long running query, use the Oracle Optimizer to pick better execution plans
Look at the DB fragmentation. Highly fragmented DBs should be defragmented
Look at the Stats gathering in the DB
SaaS / GCP customers:
Check the SaaS Service Status page to see if this is a known issue (See: Accessing Clarity SaaS Service Status Page for more details on accessing the page). If that doesn't help, create a ticket with Broadcom Technical support. Providing the below information will help in troubleshooting further:
URL(s) impacted
Area(s) impacted - Is this a general Clarity issue or specific to one particular area of Clarity?
Any recent changes or higher than usual activity occurring (such as XOG/Export to Excel)?