How to Debug Performance Management Notification email failures
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How to Debug Performance Management Notification email failures

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Article ID: 184072

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Notification emails in Performance Management are not being sent out to users.  The users report the emails are not received

This solution shows how to enable debug for failures related to email notifications for events

Environment

All Supported Performance Management environments

Cause

The debug will help determine if the problem is within the Performance Management product, or the email server receiving and sending the email request.

Resolution

Use the following instructions to enable the debug necessary to determine the cause for this problem.

  1. Go to http://<PM_HOST>:8181/pc/center/admin/debug/servers/em/admin/config/logs
  2. Find the following classes on the page:
    • com.ca.im.portal.em.notifications.EmailHandlerImpl
    • com.ca.im.portal.em.notifications.NotificationEngine
    • com.ca.im.portal.em.notifications.AndConditionFilter
    • com.ca.im.portal.em.notifications.OrConditionFilter
  3. If either class is missing use the 'Add/Update a logging category' option to add each one with the INHERITED level
  4. Change the level for each class from "INHERITED" to "TRACE"
  5. Select the Update button found at the top and bottom of the page. Refresh the page to confirm the entries are set to TRACE.
  6. Wait for new notification event emails to go out. We should see the connection to the email servers, and the email being sent out, in the enabled logging show up in the Event Manager logs.

Gather the debug logging by creating a diagnostics logging package using the Remote Engineer re.sh script.

Run the script on the Performance Management Performance Center web server and submit it to support.

Instructions are found below in Additional Information documentation link.

Additional Information

details about setting up the debug:

https://knowledge.broadcom.com/external/article?articleId=262135

details about gathering the logs:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/23-3/troubleshooting/unable-to-resolve-issue.html