ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Using Java with the Symantec Management Platform after January 2019.

book

Article ID: 173264

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Oracle is changing the Java licensing for Java 8. After January 2019, commercial customers will only be entitled to such updates if they are paying Oracle for support.

Please see the Oracle Java SE Support Roadmap for more information on the end of public updates.

Note: For further information regarding Patch Management Solution and Java, see "Patching Java 8 after January 2019 changes"

Environment

Symantec Management Platform 8.1 and 8.5

Resolution

ITMS 8.5 and 8.5 RU1 all have a dependency on Java 8.

The Management Platform help system in 8.5 RU2 now uses Java 11.

To migrate to Java 11, customers on the 8.5 and 8.5 RU1 versions should plan an upgrade to 8.5 RU2 or greater. 

Please note that no Java license is bundled with the Symantec Management Platform or management suites. Java licenses should be obtained from Oracle

Read more about this in the article, "Official Support Statement for Java and ITMS