No addresses found when using Exchange Online as source with Schemus Sync tool
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No addresses found when using Exchange Online as source with Schemus Sync tool

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Article ID: 162649

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Updated On:

Products

Email Security.cloud

Issue/Introduction

When utilizing the Schemus Synchronization Tool with Exchange Online as the data source, the synchronization may fail with the following status message:

"No addresses were found in the directory."

Cause

It appears that there is a problem with the Get-Recipient PowerShell command.

Recent Microsoft Update looks to be preventing this cmdlet from working as intended.

Resolution

The suggested workaround is to append the parameter '-Identity "*"' to the Get-Recipient command.

Schemus does not include a straightforward mechanism to pass arbitrary parameters to the PowerShell command. Instead, you can achieve a similar effect by filtering on a property which is always present such as the Distinguished Name.

  1. Select the Schemus Configuration.
  2. Click on Modify.
  3. Click on the 'Search' page in the Schemus wizard.
  4. Select 'Recipients'.
  5. Click on 'Filters'.
  6. Select the 'Filter' checkbox.
  7. Enter the following OPATH filter: DistinguishedName -like "*".
  8. Click 'OK' then Next' to confirm that recipients are retrieved once more.
  9. Save the configuration.


NOTE:

If a manual synchronization is performed or scheduled task is set up to run at a later hour/day, the synchronization will NOT fail but continue normally as it did not find any addresses in the directory, therefore the synchronization tool sees that here are 0 email addresses to be synced, deleting all of the emails addresses from the Email Security.cloud Portal.

Therefore it is important to set a maximum deleted entries limit in the mail configuration as a preventative measure.
 


NOTE:

We recommend using the Azure source if possible since this should be both more reliable and efficient.

The PowerShell source uses the Exchange PowerShell cmdlets which must be downloaded from Microsoft and imported into each PowerShell session at runtime. It is, therefore, possible for Microsoft to introduce changes to the Exchange cmdlets at any time with potentially unforeseen consequences.