VMware Tools services fail to start properly after updating PGP Encryption Management Server
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VMware Tools services fail to start properly after updating PGP Encryption Management Server

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Article ID: 157431

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Updated On:

Products

Encryption Management Server Gateway Email Encryption Desktop Email Encryption Drive Encryption Endpoint Encryption File Share Encryption PGP Command Line PGP Key Management Server PGP Key Mgmt Client Access and CLI API PGP SDK

Issue/Introduction

The information in this article is considered historical. PGP Encryption Management Server 10.5 (PGP Server) and above use native VMware tools, and do not require manual installation.  Previous versions of the PGP Encryption Management Server required installing these tools.  Rather than attempt to install these tools, please upgrade to the latest version of the PGP server.  See the Upgrade Guide for more information on this topic.

 

 

After updating PGP Encryption Management Server to a newer release that reboots the system automatically, VMware Tools services fail to start properly.

On reboot, if you press the Esc key on the keyboard to view the startup messages, you will see failures like this:

Environment

PGP Encryption Management Server 3.3 and above running as a VMware Virtual Machine.

Cause

PGP Encryption Management Server updates that include a new kernel will trigger an automatic reboot. If a new kernel is installed, VMware Tools must create a new initrd boot image for the kernel.

Resolution

If you are having issues with VMware tools, it's recommended to reach out to  Symantec Encryption Support for guidance before proceeding. 

 

Create a new initrd boot image for the kernel by running the VMware Tools "configurator":

  1. Log into the Server via SSH.
  2. At the bash shell enter this command to reconfigure VMware Tools and accept the default settings. A new initrd boot image for the kernel will be created:
    vmware-config-tools.pl -d
  3. Reboot the server and check that VMware Tools loads successfully.