Cannot start EM after applying HF49 - Unable to load the RocksDB shared libraryjava.io.IOException: No such file or directory
search cancel

Cannot start EM after applying HF49 - Unable to load the RocksDB shared libraryjava.io.IOException: No such file or directory

book

Article ID: 139684

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

After applying the 10.7 Hotfix 49 it was possible to start the EM with the output:

11/05/19 08:21:20.533 AM WET [INFO] [main] [Manager.ServerSocketFactory] Created Server Socket Factory: com.wily.jip.server.ext.DefaultServerSocketFactory
11/05/19 08:21:20.557 AM WET [ERROR] [main] [Manager] The EM failed to start. null

when DEBUG logging was enabled further detail was available

11/05/19 08:24:02.675 AM WET [DEBUG] [main] [Manager] Error starting up EM
com.wily.introscope.server.enterprise.EnterpriseManagerCannotStartException: An error occurred while trying to start Isengard.
    at com.wily.introscope.server.enterprise.EnterpriseServer.doStart(EnterpriseServer.java:424)
    at com.wily.util.ALifeCycle.start(ALifeCycle.java:86)
    at com.wily.introscope.server.enterprise.EnterpriseServer.<init>(EnterpriseServer.java:330)
    at com.wily.introscope.server.enterprise.EnterpriseServer.<init>(EnterpriseServer.java:309)
    at com.wily.introscope.server.enterprise.EnterpriseServer.start(EnterpriseServer.java:1616)
    at com.wily.introscope.em.internal.Activator.startEM(Activator.java:119)
    at com.wily.introscope.em.internal.Application.start(Application.java:27)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1212)
    at org.eclipse.core.launcher.Main.main(Main.java:30)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.zerog.lax.LAX.launch(Unknown Source)
    at com.zerog.lax.LAX.main(Unknown Source)
Caused by: java.lang.ExceptionInInitializerError
    at org.rocksdb.Options.<clinit>(Options.java:21)
    at com.wily.introscope.server.enterprise.entity.rocksdb.RocksDBSystem.<init>(RocksDBSystem.java:50)
    at com.wily.introscope.server.enterprise.entity.rocksdb.RocksDBEntityImpl.<init>(RocksDBEntityImpl.java:36)
    at com.wily.introscope.server.enterprise.EnterpriseServer.initialize(EnterpriseServer.java:597)
    at com.wily.introscope.server.enterprise.EnterpriseServer.doStart(EnterpriseServer.java:387)
    ... 26 more
Caused by: java.lang.RuntimeException: Unable to load the RocksDB shared libraryjava.io.IOException: No such file or directory
    at org.rocksdb.RocksDB.loadLibrary(RocksDB.java:51)
    at org.rocksdb.RocksDB.<clinit>(RocksDB.java:23)
    ... 31 more

Environment

Release : 10.7.0

Component : Introscope

Cause

The RocksBD shared library is created dynamically during initialisation of the Enterprise Manager in the work folder - if this fails for any reason the Enterprise manager will not start

Resolution

Clearing the Enterprise manager cache as per the procedure described in the following KB article resolved the problem

 

https://knowledge.broadcom.com/external/article?articleId=100299