Data missing in DWH in FACTS tables and on reports due to Time zone mismatch
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Data missing in DWH in FACTS tables and on reports due to Time zone mismatch

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Article ID: 128030

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Significant data is missing in some of the reports and in the Data Warehouse (DWH). The FACTS tables do not have most of the data. The jobs run as expected.

Environment

Release: Any

Cause

The times between Database and Application are mismatched by more than 15 sec.

This can be seen in Administration -> Health Report -> Database

Parameter: Application and Database Timezone Match

Resolution

  1. Ensure that the time/date between the Application server and the database server is the same up to the second. This is a requirement for Data Warehouse to work in order to match the dates between database and application.
  2. Once the times are synced up, run Load Data Warehouse - Full Load and check the data again.

Note: If you are using a time sync service to sync the server to the correct time, ensure the service is up and running.

Additional Information