IMS1001 error when Attaching files to xFlow Service Point ticket
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IMS1001 error when Attaching files to xFlow Service Point ticket

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Article ID: 104902

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Updated On: 03-31-2025

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

The following error appears when attaching a file to xFlow/Service Point ticket:

IMS1001-File extension .XXX is either upload prohibited or it does not match the content type application/XXX

Environment

Service Desk Manager 17.x
xFlow / Service Point 17.x

Cause

There are two possible causes for this error:

1. The file extensions is not allowed in xFlow.

2. The extension does not match the content type of the file.

Resolution

Cause 1:

Add the extension to the allowed list:

1. Log into Service Desk as an Administrator and go to > Administration tab > xFlow Analyst Interface > General

2. Open attachments.allowed-content-types > Edit

3. Add the extension and MIME type.

Example 1: To add .rar files:

.rar:application/x-rar-compressed

Where .rar is the extension and application/x-rar-compressed is the MIME Type.

Example 2: To add .sql files:

.sql:text/plain

The List of MIME Types is in the link under "Additional Information".

4. Restart xFlow services.

 

Cause 2:

Change the extension to the right one, so it does not fail when verifying the extension.

Additional Information