System Requirements for Symantec Information Centric Tagging 15.5 and 15.1

book

Article ID: 171771

calendar_today

Updated On:

Products

Information Centric Tagging Information Centric Security

Issue/Introduction

This article lists the current system requirements and supported platforms for versions 15.5 and 15.1 of Symantec Information Centric Tagging and Symantec Information Centric Security Module, including the Maintenance Pack (MP) releases. The Prerequisites Specification documents are also attached to this article. To download a document, click a document link under the Related Attachments section at the bottom of the page.

NOTE: This article will be updated as additional platforms or other system requirements are tested and added for Symantec Information Centric Tagging (ICT) and Symantec Information Centric Security Module (ICSM). To receive email notifications when this article is updated with new information, click Subscribe under the Subscribe to this Article section at the bottom of the page.

Resolution

Supported Platforms

Symantec Information Centric Tagging and Symantec Information Centric Security Module are compatible with the following platforms on server systems and Windows client systems.

NOTE: Refer to the Deprecated Platforms section in this article to know which platforms are being deprecated and which will be removed in a future release.

Server-side

  • Server OS: Microsoft Windows Server 2008 R2, 2008 R2 SP1, 2012, 2012 R2, 2016, 2019 (Datacenter edition)
  • AD: Microsoft Windows Active Directory 2003, 2008 R2, 2013, 2016  
  • Database: Microsoft SQL Server 2008 R2, 2012, 2014, 2014 SP1, 2016 (Standard edition)
  • RMS: Microsoft Active Directory Rights Management Services 2008 R2 SP1, 2012, 2012 R2 (On-Premises)
  • Azure RMS: Microsoft Azure Rights Management
  • Mail Servers (Outlook Web Access): Microsoft Exchange Server 2013 Cumulative Update 23 version 15.00.1497.002 (KB099855), Microsoft Exchange Server 2013 Cumulative Update 21 version 15.00.1395.004 (KB4099855), Microsoft Exchange Server 2010 SP2 or later
  • IIS: Internet Information Services (IIS) 7.0 or later
  • .NET: Microsoft .NET Framework 3.5, 4.5 or later
  • Browsers: Microsoft Windows Internet Explorer 9, 10, 11

Client-side (Windows) 

  • Client OS: Microsoft Windows 8.1, 10 (through Version 1909, November 2019 Update)
  • Office: Microsoft Office (Word, Excel, PowerPoint, Outlook) 2010 (Standard and Professional Plus), 2013 (O365, Standard, Professional, and Professional Plus), 2016 (O365, Standard, Professional, and Professional Plus), 2019 (O365, Standard, Professional, and Professional Plus)
    NOTE: Integration of ICT or ICSM with Microsoft RMS encryption is supported only on the following Office editions that allow users to create RMS-encrypted content and consume RMS-encrypted content: Microsoft Office 2010 SP2, 2013, 2016 (Professional Plus, Enterprise, and Ultimate), Microsoft Office O365 (Professional Plus and Enterprise E3),  2019 (O365, Standard, Professional, and Professional Plus)
  • .NET: Microsoft .NET Framework 3.5.x, 4.5.x, 4.6.x, and 4.7.x
  • Browsers: Microsoft Windows Internet Explorer 9, 10, 11
  • Email clients: Microsoft Outlook 2010, 2013, 2016, Microsoft Outlook on the web (OWA)
  • Encryption: Symantec Information Centric Encryption (ICE), Ionic Office Plugin 0.93.0.9, Active Directory Rights Management Services Client 2.x (1.0.2217.0)

NOTE: The macOS client systems are no longer supported with ICT and ICSM.

Command Line Interface

NOTE: Symantec Information Centric Tagging Command Line Interface is being deprecated in version 15.5 MP2. A new ICT command-line interface, File Tagger tool, is available starting from version 15.5 MP2. Use the File Tagger tool to perform data classification and data protection functions. Symantec Information Centric Tagging Command Line Interface will not be available or supported in a future release of ICT.

  • Server OS: Microsoft Windows Server 2012 R2, 2012, 2008 R2 SP1
  • Office: Microsoft Office (Word, Excel, PowerPoint, Outlook) 2010 (Standard and Professional Plus), 2013 (O365, Standard, Professional, and Professional Plus), 2016 (O365, Standard, Professional, and Professional Plus), ​ 2019 (O365, Standard, Professional, and Professional Plus)
    NOTE: Integration of ICT or ICSM with Microsoft RMS encryption is supported only on the following Office editions that allow users to create RMS-encrypted content and consume RMS-encrypted content: Microsoft Office 2010, 2013 (Professional Plus), 2016 (Professional Plus); Microsoft Office 2013 (O365), 2016 (O365); 2019 (O365, Standard, Professional, and Professional Plus)
  • .NET: Microsoft .NET Framework 3.5.x, 4.5.x, 4.6.x, and 4.7.x
  • Ionic App Development: Ionic Command Line Interface 1.2.0

Virtualization

  • Server: Citrix Server 2012 R2, 2008 R2
  • VDI: Microsoft Windows Server 2012 R2
  • VDA: Server OS/Desktop OS Virtual Delivery Agent 7.6.300 or later
  • Desktop virtualization: Citrix XenApp and XenDesktop 7.6, 7.15, 7.18, 7.19; VMware Horizon 7.11.0 (formerly called Horizon View)
  • Client component: Citrix Receiver 14.1.200.13

Rights Management Services

  • Active Directory Rights Management Services Client 2.x (1.0.2217.0)
  • Microsoft Rights Management sharing application 1.0.2217.0
  • Microsoft Office Add-ins 1.0.23

Azure

  • Microsoft Azure AD Connect 1.3.21.0
  • Microsoft Azure AD Connect Health agent for Sync 3.1.41.0
  • Microsoft Azure Active Directory Connect synchronization services 1.3.21.0
  • Microsoft Azure Active Directory Connect
  • Microsoft Online Services Sign-in Assistant for IT Professionals RTW
  • Microsoft Windows Management Framework 5.1
  • Microsoft Azure Active Directory Module for Windows PowerShell 1.1.183.17
  • AADRM Powershell Module 2.13.1.0
  • Microsoft Active Directory Rights Management Services Client 2.x 1.0.2217.0
  • Microsoft Online Services Sign-in Assistant 7.250.4556.0

Ionic

  • Ionic Office Plugin 0.93.0.9
  • Ionic CLI 1.2.0

Deprecated Platforms

The following platforms are deprecated in version 15.5 MP2, and support for these platforms will be removed in a future release of ICT:

  • Microsoft Windows 7
  • Microsoft Office 2010
  • Microsoft Internet Explorer 9 and 10
  • Microsoft Windows Server 2008 R2
    NOTE: Applies also to AD RMS running on Windows Server 2008 R2

Supported Languages

  • Arabic (UAE)
  • Chinese (Simplified; PRC)
  • Chinese (Traditional; Taiwan)
  • English (United States)
  • French (France)
  • German (Germany)
  • Italian (Italy)
  • Japanese (Japan)
  • Korean (Korea)
  • Portuguese (Brasil)
  • Portuguese (Portugal)
  • Spanish (Spain; International Sort)
  • Turkish (Turkey)

Update History

Added support for

Removed support for

Affected version

Date

Microsoft Windows 10 November 2019 Update (version 1903 and 1909) (32-bit and 64-bit)   15.5
Also supported on 15.1
June 2020
  Microsoft Windows 7 15.5, 15.1 June 2020
VMware Horizon 7.11 (Horizon View)   15.5 MP3 Feb 18 2020
Microsoft Exchange Server 2013 Cumulative Update 23 version 15.00.1497.002 (KB099855)    15.5 MP3 Feb 12 2020

Citrix XenApp and XenDesktop 7.19 

 

15.5 MP1

July 2019

Citrix XenApp and XenDesktop 7.15 The Long Term Service Release (LTSR) Cumulative Update 4 (CU4)

 

15.5 MP1

July 2019

Microsoft Windows Server 2019 Datacenter (64-bit)

 

15.5

Also supported on 15.1

March 2019

Microsoft Windows 10 Enterprise October 2018 Update (version 1809) (32-bit and 64-bit)

 

15.5

Dec 2018

Microsoft Office 365 and Microsoft Office 2019 (32-bit and 64-bit)

 

15.5

Dec 2018

Microsoft SQL Server 2014 Standard Edition (32-bit and 64-bit)

 

15.5

Also supported on 15.1 and 15.0

Dec 2018

Microsoft Exchange Server 2013 Cumulative Update 21 (KB4099855) version 15.00.1395.004

 

15.5

Dec 2018

Chinese (Traditional; Taiwan), Italian (Italy), Korean (Korea), Portuguese (Brasil), and Turkish (Turkey)

 

15.5

Dec

2018

 

Microsoft Exchange Server 2013
Cumulative Update 19
(KB4037224) version
15.00.1365.001
​​​​

15.5

Dec 2018

Microsoft Windows Server 2019 Datacenter (64-bit)

 

15.1

March 2019

Citrix XenDesktop 7.18

 

 15.1

Aug 2018

Microsoft Windows Server 2016 (64-bit)

 

 15.1

June 2018

Microsoft SQL Server 2016 (64-bit)

 

 15.1

June 2018

Microsoft SQL Server 2014 Service Pack 1 (SP1) (32-bit and 64-bit)

 

 15.1

June 2018

Cumulative Update 19 (KB4037224) version 15.00.1365.001 for Microsoft Exchange Server 2013 

 

 15.1

June 2018

Microsoft Windows 10 Creators Update (32-bit and 64-bit)

Microsoft Windows 10 Fall Creators Update (32-bit and 64-bit)

 

 15.1

June 2018

Japanese language

 

 15.1

June 2018

References

For understanding compatibility between various Microsoft platforms and supported features, refer to the following Microsoft articles:

Attachments

Symantec_ICT_15.5_Prerequisites_Specification.pdf get_app
Symantec_ICT_15.1_Prerequisites_Specification.pdf get_app