Oracle database version upgrade requirements for Enforce server and Detection Servers