The software update fails with the error: "Err Inappropriate ioctl for device" due to unmet dependencies