How to upgrade Guardian Edge(GE) server software to Symantec Endpoint Encryption(SEE) server software.

book

Article ID: 154162

calendar_today

Updated On:

Products

Endpoint Encryption

Issue/Introduction

You wish to know the procedure to upgrade GE Management server to  SEE Management Server.

Resolution

 

Upgrades of the Management Server differ according to the type of database utilized by the version you are upgrading from.

 

  • Active Directory Application Mode (ADAM) database—Symantec Endpoint Encryption version numbers less than 7.0.0 and GuardianEdge Framework version numbers less than 9.2.0 utilize an ADAM database. Refer to“From Versions that Utilize an ADAM Database” in the Installation Guide.
  • SQL database—Symantec Endpoint Encryption version numbers that are equal to or greater than 7.0.0 and GuardianEdge Framework version numbers that are equal to or greater than 9.2.0 rely on a SQL database. If you are upgrading from a version that utilizes a SQL database, continue reading.

The GE Management Server components should be upgraded in the following order and manner:

  1. Install the Management server package ("Symantec Endpoint Encryption Management Server.msi") directly by double-clicking (the installer will detect the previous GE installation).*
  2. Reboot the system.
  3. Install the Framework package from a command prompt using the reinstallation switches (msiexec /i "Symantec Endpoint Encryption Framework.msi" REINSTALL="All" REINSTALLMODE="vomus")
  4. Reboot the system.
  5. Install the Full Disk Encryption package from a command prompt using the reinstallation switches (msiexec /i "Symantec Endpoint Encryption Full Disk Edition.msi" REINSTALL="All" REINSTALLMODE="vomus")
  6. Reboot the system.
  7. Install the Removable Storage Encryption package from a command prompt using the reinstallation switches (msiexec /i "Symantec Endpoint Encryption - Removable Storage Edition.msi" REINSTALL="All" REINSTALLMODE="vomus")
  8. Reboot the system.


*Note: Using the reinstallation switches with the Management Server package will cause a SQL error as outlined in this KB:
http://service1.symantec.com/support/ent-security.nsf/docid/2009091413225448

This information applies to all versions of GE from 9.2.0 and up.