List of Linux Distributions and Kernels with Precompiled Auto-Protect Drivers/Modules for Symantec Endpoint Protection for Linux 14.x

book

Article ID: 150469

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

The list within this knowledge base article outlines all Symantec Endpoint Protection for Linux (SEPFL) v14.x releases and which Linux distribution(s) and kernel version(s) for which precompiled drivers (modules) for Auto-Protect are included in the SEP for Linux version package. This list is NOT meant to be used to determine if a specific Linux distro and kernel version combination are ultimately supported by the SEP for Linux client. If the SEP for Linux installer does not include precompiled kernel drivers for Auto-Protect for the Linux distro and kernel version, an automatic process will attempt to compile the specific kernel drivers for Auto-Protect during the install process.

Resolution

This list should not be considered complete and exclusive. Unless specified otherwise, kernel versions apply to both 32- and 64-bit kernels. Linux operating systems and kernels that do not appear on this list may successfully install and enable the Auto-Protect kernel module. Before assuming the kernel isn't supported, test with the latest version of Symantec Endpoint Protection for Linux. If you find an issue with an auto-compiled AP module, open a case with Broadcom Support. The support team will work with Engineering to evaluate any compatibility issues on a case-by-case basis.

Note: Red Hat introduced RETPOLINE to their kernel starting with 3.10.0-693.21.1.el7.x86_64 to provide Spectre2 mitigation support. As of 14.2 MP1, our Auto-Protect startup script will not load pre-built AP kernel modules build with the CONFIG-RETPOLINE flag. Instead Auto-Compile will be triggered. This is to address an issue in which kernel modules not compiled with config_retpoline aware compilers will cause a kernel panic.

The following Linux operating system kernel versions have been tested and should successfully install and enable the precompiled kernel modules for Auto-Protect, or successfully install and enable the auto-compiled kernel modules for Auto-Protect:

Operating System Kernel version
Amazon Linux AMI 2016.03 4.4.8-20.46.amzn1.x86_64
4.4.11.23.53.amzn1.x86_64
Amazon Linux AMI 2018.03 4.14 (Available in 14.2.1015.0100 or later)
Amazon Linux 2 4.14 (Available in 14.3.1148.0100 or later)
CentOS 6.3 (Final) 2.6.32-279.el6
CentOS 6.4 (Final) 2.6.32-358.11.1.el6
CentOS 6.5 (Final) 2.6.32-431.29.2.el6
CentOS 6.6 (Final) 2.6.32-504.el6
CentOS 6.9 2.6.32-696.el6.x86_64
2.6.32-696.18.7.el6.x86_64 (Available in 14.0.3876.1100 or later)
CentOS 6.10 2.6.32-754.el6.x86_64 (Available in 14.2.1015.0100 or later)
CentOS 7.0 3.10.0-123.20.1.el7.x86_64
CentOS 7.1 3.10.0-229.7.2.el7.x86_64
CentOS 7.2 3.10.0.327.4.4
CentOS 7.3 3.10.0.514.2.2 (Available in 14.0.2332.0100)
CentOS 7.4 3.10.0-693.el7.x86_64 (Available in 14.0.3876.1100 or later)
3.10.0-693.11.6.el7.x86_84 (Available in 14.0.3929.1200 or later)
CentOS 7.5 3.10.0-862.el7.x86_64 (Available in 14.2.1015.0100 or later)
CentOS 7.x (w/ Google BBR kernel) 4.15.10-1.el7.elrepo.x86_64 (Available in 14.2.3332.1000 or later)
CentOS 7.7 3.10.0-1062 (Available in 14.2.5323.2000 or later)
CentOS 8 4.18 (Available in 14.2.5569.2100 or later)
Debian GNU/Linux 7 3.2.0-4-amd64
Debian GNU/Linux 7 3.2.0-4-686-pae
Debian GNU/Linux 8 3.16.0-4-amd64
Debian GNU/Linux 8 3.16.0-4-686-pae
3.16.0 (Added for 14.2.3332.1000 or later)
Oracle Enterprise Linux 6.8 4.1.12-37.4.1.el6uek.x86_64 (Available in 14.0.3929.1200 or later)
RedHat Compatible Kernel 2.6.32-642.el6.x86_64 (RHK) (Available in 14.0.3929.1200 or later)
4.1.12-124.15.4.el6uek.x86_64 (Available in 14.2.758.0000 or later)
Oracle Enterprise Linux 7.0 3.8.13-98.1.1.el7uek.x86_64
Oracle Enterprise Linux 7.1 3.8.13-55.1.6.el7uek.x86_64 (Available in 14.0.2332.0100 or later)
Oracle Enterprise Linux 7.2 3.8.13-95.7.1.el7uek.x86_64 (Available in 14.0.2332.0100 or later)
4.1.12-112.14.11.el7uek.x86_64 (Available in 14.0.3929.1200 or later)
Oracle Enterprise Linux 7.3 4.1.12-61.1.28.el7uek.x86_64 (Available in 14.0.2332.0100 or later)
Oracle Enterprise Linux 7.4 4.1.12-94.3.9.el7uek.x86_64 (Available in 14.2.1015.0100 or later)
Oracle Linux Server 6.4 2.6.32-358.6.2.el6.x86_64
4.1.12-112.14.11.el6uek.x86_64 (Available in 14.0.3929.1200 or later)
Oracle Linux Server 6.5 3.8.13-98.el6uek.x86_64
Oracle Linux Server 6.10 2.6.32-754.9.1.el6.x86_64 (Verified in 14.2.1015.0100)
Oracle Linux Server 7.6 3.10.0-957.1.3.el7.x86_64 (Verified in 14.2.1015.0100)
Red Hat Enterprise Linux Server 6.2 (Santiago) 2.6.32-220.el6
Red Hat Enterprise Linux Server 6.3 (Santiago) 2.6.32-279.el6
Red Hat Enterprise Linux Server 6.4 (Santiago) 2.6.32-358.6.2.el6
Red Hat Enterprise Linux Server 6.5 (Santiago) 2.6.32-431.59.1.el6
Red Hat Enterprise Linux Server 6.6 (Santiago) 2.6.32-504.30.3.el6
Red Hat Enterprise Linux Server 6.7 2.6.32-573.el6.x86_64 (Available in 14.2.1015.0100 or later)
Red Hat Enterprise Linux Server 6.9  2.6.32-696.el6.x86_64
2.6.32-696.18.7.el6.x86_64 (Available in 14.0.3929.1200 or later)
Red Hat Enterprise Linux Server 6.10 2.6.32-754.el6.x86_64 (Available in14.2.1015.0100 or later)
Red Hat Enterprise Linux Server 7.0 3.10.0-123.20.1.el7.x86_64
Red Hat Enterprise Linux Server 7.1 3.10.0-229.7.2.el7.x86_64
Red Hat Enterprise Linux Server 7.2 3.10.0-327.4.5.el7.x86_64
Red Hat Enterprise Linux Server 7.3 3.10.0-514.el7.x86_64 (Available in 14.0.2332.0100 or later)
Red Hat Enterprise Linux Server 7.4 3.10.0-693.el7.x86_64 (Available in 14.0.3752.1000 or later)
3.10.0-693.11.6.el7.x86_64 (Available in 14.0.3929.1200 or later)
3.10.0-693.2.2.e17.x86_64 (Available in 14.2.758.0000 or later)
Red Hat Enterprise Linux Server 7.5 3.10.0-862.el7.x86_64 (Available in 14.2.1015.0100 or later)
Red Hat Enterprise Linux Server 7.6 3.10.0-957.el7.x86_64 (Available in 14.2.1015.0100 or later)
Red Hat Enterprise Linux Server 7.7 3.10.0-1062.el7.x86_64 (Available in 14.2.4811.1100 or later)
Red Hat Enterprise Linux Server 7.8 3.10.0-1127 (Available in 14.3 and later)
Red Hat Enterprise Linux Server 8 4.18.0-80.el8.x86_64  (Available in 14.2.5569.2100 or later)
Red Hat Enterprise Linux Server 8.1 4.18.0-147.el8.x86_64  (Available in 14.2.5569.2100 or later)
Red Hat Enterprise Linux Server 8.2 4.18.0-193 (Available in 14.3 and later)
SUSE Linux Enterprise Desktop 11 SP3 (i586) 3.0.76-0.11-pae
SUSE Linux Enterprise Desktop 11 SP3 (i586) 3.0.76-0.11-pae
SUSE Linux Enterprise Desktop 11 SP3 (x86_64) 3.0.76-0.11-default
SUSE Linux Enterprise Desktop 11 SP4 (32-bit) 3.0.101-63-pae (14.0.2415.0200)
SUSE Linux Enterprise Desktop 11 SP4 (64-bit) 3.0.101-63-default (14.0.2415.0200)
SUSE Linux Enterprise Desktop 12 SP3 4.4.73-5-default (Available in 14.0.3752.1000 or later)
SUSE Linux Enterprise Server 11 SP3 (i586) 3.0.76-0.11-default
SUSE Linux Enterprise Server 11 SP3 (x86_64) 3.0.76-0.11-default
SUSE Linux Enterprise Server 11 SP4 (32-bit) 3.0.101-63-pae (14.0.2415.0200)
SUSE Linux Enterprise Server 11 SP4 (64-bit) 3.0.101-63-default (14.0.2415.0200)
3.0.101-108.21-default (Available in 14.0.3929.1200 or later)
SUSE Linux Enterprise Server 12 (x86_64) 3.12.49-11-default
SUSE Linux Enterprise Server 12 SP1 (x86_64) 3.12.49-11-default
3.12.53-60.30-default
SUSE Linux Enterprise Server 12 SP2 (x86_64) 4.4.103-92.56-default (Available in 14.0.3929.1200 or later)
SUSE Linux Enterprise Server 12 SP3 (x86_64) 4.4.73-5-default (Available in 14.0.3752.1000 or later)
SUSE Linux Enterprise Server 12 SP4 (x86_64) 4.12.14-94.41-default (Verified in 14.2.4811.1100)
SUSE Linux Enterprise Server 15 4.12.14-25.25 (Available in 14.2.3332.1000 or later)
Ubuntu 12.04.4 LTS 3.2.0-55-generic-pae
Ubuntu 14.04 LTS 3.13.0-63-generic
3.13.0-139-generic (Available in 14.0.3929.1200 or later)
Ubuntu 15.10 4.2.0-41-generic
Ubuntu 16.04 LTS 4.4.0-38-generic
4.4.0-109-generic (Available in 14.0.3929.1200 or later)
4.11.0-13-generic (Available in 14.0.3929.1200 or later)
4.13.0-26-generic up to 4.13.0-36-generic (Available in 14.2.758.0000 or later)
4.13.0-41-generic (Available in 14.2.1015.0100 or later)
4.15.0-15-generic (Available in 14.2.3332.1000 or later)
Ubuntu 18.04(.02*) LTS

(Available in 14.2.3332.1000 or later)
4.15.0-39
4.15.0-44
4.15.0-45
4.15.0-48
4.15.1-041501
4.15.2-041502
4.15.5-041505

(Available in 14.2.5569.2100 or later)
4.18
5.0

 

For general system requirements and a more complete list of supported operating systems, see System requirements for all releases of Symantec Endpoint Protection.

For more information on how auto-compile works, including prerequisites, see Auto-compile for Symantec Endpoint Protection client for Linux.