search cancel

Cannot update Messaging Gateway 10.7.0 - Unable to access repository.

book

Article ID: 175460

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

Attempting to update Messaging Gateway (SMG) version 10.7.0 to SMG 10.7.1 or later fails with the error message that SMG is "Unable to access the respoitory":

smg [10.7.0-5]> update list
Installed Packages
sms-appliance-release.noarch  10.7.0-5  symrepo_smg
Unable to access repository.
Unable to access repository.

Cause

If SMG is using a proxy server which requires a password to connect to the internet, SMG 10.7.0 is not correctly authenticating to the proxy server.

Resolution

This proxy authentication issue is addressed with the SMG 10.7.1 release but due to the nature of the issue, SMG 10.7.0 cannot be updated using a password protected proxy server.

Workaround

  1. Disable the proxy server in Adminstration > Configuration > Proxy
  2. Apply Patch 275 for SMG 10.7.0 via localinstall as shown below

Applying Patch 275 to SMG 10.7.0

Since SMG 10.7.0 cannoth athenticate to the proxy server, the patch cannot be downloaded and installed via the standard process but will need to uploaded directly to the SMG appliance and installed via the 'patch localinstall' mechanism.

  1. Download the patch file attached to this document
  2. Uncompress and unpack the tar archive file
  3. Log into the SMG appliance command line (CLI) as 'admin'
  4. Enable the support account via the set-support command
  5. Copy the patch iso file to the /data/tmp directory on the appliance as support using WinSCP or some other scp client and the support account credentials
  6. From the admin CLI, run patch localinstall file:///data/tmp/sms-appliance-patch-10.7.0-275.iso
  7. Following the reboot, from the admin CLI, run update list to confirm that proxy authentication is working as expected
  8. Update to SMG 10.7.1 via either the admin CLI or Control Center as usual

Attachments

smgapp1070_p275_swupdate_x86_64_linux.tar.gz get_app