Software Portal UI (client side): Software list may contain records with blank Software Names.

book

Article ID: 164134

calendar_today

Updated On:

Products

Software Management Solution

Issue/Introduction

A user logs in to Software Portal and sees many entries with blank names and descriptions. The user starts scrolling and the blank names disappear. Count of available software may change when scrolling up or down the list.



 

No errors in the log.

Cause

Defect. Deficiency in the "spSWP_GetSoftwarePublishingItem" stored procedure logic.

Environment

SMP 7.6 - 7.6 HF7.

Resolution

Install the attached point-fix.

NB!!! The fix is "cumulative" in nature and thereoferofe serveral problems will be resolved once installed. Check out  "SWM.reg" file for more details. INFO3459 will be updated. 

PREREQUISITE

SMP 7.6 HF7.

HOW TO INSTALL

1.    Retrieve files from the archive to the NS hard drive.
2.    Make sure PointFix is extracted not to Altiris install directory (or any subfolder to it)!!!
3.    Run as administrator PFinstaller2.EXE, click on 'Install' button
4.    Accept UAC (User Account Control) prompt, select Install Files. Old files will be automatically backup to the Backup folder at the same location where PFinstaller is and replaced with the new ones. Log-file Log.txt will be created at the same location where PFinstaller is.

HOW TO UNINSTALL

1.    Make sure that Backup subfolder is located in ULM directory
2.    Execute PFInstaller2.exe with administrative privileges (right-click > Run as administrator).
3.    Accept UAC (User Account Control) prompt, select Uninstall.
NOTE: spSWP_GetSoftwarePublishingItem stored procedure will not be reverted after PF uninstallation, only dll files stored in backup folder will be reverted back.

CHANGES MADE

Changed spSWP_GetSoftwarePublishingItem.sql to not show disabled Items.

The fix will be incorporated into ITMS 8.1 release.

 

Attachments

SWM.zip get_app